# CVE-2026-41512: Remote code execution via JavaScript injection in `BrowserAutomation::PlaywrightService`

> Attackers can execute arbitrary code via JavaScript injection in the Playwright service of the ai-scanner library.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-r27j-xxgx-f5vr

## What is CVE-2026-41512?

CVE-2026-41512 is a critical code injection vulnerability in 0din-ai ai-scanner, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ai-scanner is an AI model safety scanner built on NVIDIA garak. From version 1.0.0 to before version 1.4.1, there is a remote code execution vulnerability via JavaScript injection in `BrowserAutomation::PlaywrightService`. This issue has been patched in version 1.4.1.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-41512?

It affects 1 product.


Products: Mozilla 0din Scanner.

## How do I fix CVE-2026-41512?

No fix has been published for CVE-2026-41512 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-41512 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41512 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41512 and fix it if it is affected.

What it is: CVE-2026-41512 is a critical code injection vulnerability in 0din-ai ai-scanner, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41512 exists.

Affected product: 0din-ai ai-scanner. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41512/ (Markdown: https://insights.sbomify.com/CVE-2026-41512/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41512
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41512
- OSV: https://osv.dev/vulnerability/CVE-2026-41512

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41512/
Summaries are generated and may contain mistakes; the official description above is the record.
