# CVE-2026-41520: Cillium exposes sensitive information included in the cilium-bugtool debug archive

> Attackers can obtain sensitive data from Cilium bugtool archives when WireGuard encryption is enabled, requiring an upgrade to patched versions.

- **Severity:** High 7.9 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 13 May 2026
- **Also known as:** BIT-cilium-2026-41520, BIT-cilium-operator-2026-41520, BIT-hubble-relay-2026-41520, GHSA-gj49-89wh-h4gj, GO-2026-5400, MINI-2982-g347-rjq7, MINI-398c-766m-jgxg, MINI-3g7g-7w5r-w24g, MINI-5gfj-vj9c-x7gq, MINI-6xfm-q37g-9mx6, MINI-8cfm-rvvq-r7wm, MINI-8jw2-8f5r-r59v, MINI-99rq-c3pm-2gm9, MINI-f5q5-282j-fvj4, MINI-f8cc-3cv4-5cp4, MINI-fm2w-5gp6-2pq5, MINI-hh56-836r-2r7j, MINI-m338-58xh-hr6c, MINI-p863-67r3-vfpc, MINI-q273-px8m-r54v, MINI-q4cw-492g-9mhw, MINI-x7vg-6rcv-fff8, MINI-xj9p-qqfh-pcm8

## What is CVE-2026-41520?

CVE-2026-41520 is a high-severity vulnerability in cilium, published on 8 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Prior to versions 1.17.15, 1.18.9, and 1.19.3, the output of cilium-bugtool can contain sensitive data when the tool is run against Cilium deployments with WireGuard encryption enabled. This issue has been patched in versions 1.17.15, 1.18.9, and 1.19.3.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-41520?

10 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | All versions | 1.17.15, 1.18.9, 1.19.3 |
| `github.com/cilium/cilium` | Go | All versions | 1.17.15 |
| `github.com/cilium/cilium` | Go | All versions | 1.17.15 |
| `github.com/cilium/cilium` | Go | From 1.18.0 | 1.18.9 |
| `github.com/cilium/cilium` | Go | From 1.18.0 | 1.18.9 |
| `github.com/cilium/cilium` | Go | From 1.19.0 | 1.19.3 |
| `github.com/cilium/cilium` | Go | From 1.19.0 | 1.19.3 |
| `cilium` | Bitnami | All versions | 1.17.15, 1.18.9, 1.19.3 |
| `cilium-operator` | Bitnami | All versions | 1.17.15, 1.18.9, 1.19.3 |
| `hubble-relay` | Bitnami | All versions | 1.17.15, 1.18.9, 1.19.3 |

Products: Cilium Cilium.

## How do I fix CVE-2026-41520?

Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.17.15, 1.18.9 or 1.19.3.

## Is CVE-2026-41520 being exploited?

There is no known exploitation of CVE-2026-41520 in the wild and no public exploit code.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2024-37307](https://insights.sbomify.com/CVE-2024-37307/): Cilium leaks sensitive information in cilium-bugtool (high 7.9)
- [CVE-2023-39347](https://insights.sbomify.com/CVE-2023-39347/): Cilium NetworkPolicy bypass via pod labels (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41520 and fix it if it is affected.

What it is: CVE-2026-41520 is a high-severity vulnerability in cilium, published on 8 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41520 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.17.15, 1.18.9, 1.19.3
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.17.15
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.17.15
- github.com/cilium/cilium (Go): affected from 1.18.0; fixed in 1.18.9
- github.com/cilium/cilium (Go): affected from 1.18.0; fixed in 1.18.9
- github.com/cilium/cilium (Go): affected from 1.19.0; fixed in 1.19.3
- github.com/cilium/cilium (Go): affected from 1.19.0; fixed in 1.19.3
- cilium (Bitnami): affected all versions; fixed in 1.17.15, 1.18.9, 1.19.3
- cilium-operator (Bitnami): affected all versions; fixed in 1.17.15, 1.18.9, 1.19.3
- hubble-relay (Bitnami): affected all versions; fixed in 1.17.15, 1.18.9, 1.19.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41520/ (Markdown: https://insights.sbomify.com/CVE-2026-41520/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41520
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41520
- OSV: https://osv.dev/vulnerability/CVE-2026-41520

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41520/
Summaries are generated and may contain mistakes; the official description above is the record.
