CVE-2026-41521 xrdp: lib_framebuffer_update Has Integer Overflow Heap Info Leak & ASLR Bypass

High 8.2 Published Updated

A malicious remote VNC server can trigger an integer overflow in xrdp to leak heap memory or crash the service via crafted image dimensions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41521?

CVE-2026-41521 is a high-severity vulnerability in neutrinolabs xrdp, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

xrdp is an open source RDP server. Versions 0.10.6 and prior contain an integer overflow vulnerability when processing screen update messages within the vnc-any connection mode. A malicious remote VNC server can send crafted image dimensions that cause an integer overflow during memory buffer size calculation, resulting in an undersized allocation. Subsequent processing of the incoming image data using the original oversized parameters leads to an out-of-bounds read. An unauthenticated remote attacker could exploit this flaw to disclose sensitive information from the heap memory or cause a denial of service (DoS) via a process crash. This issue has been fixed in version 0.10.6.1.

Weakness: CWE-190

Which versions are affected by CVE-2026-41521?

It affects 1 product.

Products include Neutrinolabs Xrdp.

How do I fix CVE-2026-41521?

Upgrade to a fixed version.

Is CVE-2026-41521 being exploited?

There is no known exploitation of CVE-2026-41521 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-41521, GHSA-v8w6-pf78-9458, UBUNTU-CVE-2026-41521.

Is CVE-2026-41521 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free