# CVE-2026-41523: vLLM: Security Check Bypass via assert Statement in Activation Function Loading Allows Arbitrary Code Execution

> Attackers can execute arbitrary code on vLLM servers by publishing malicious models when the server runs in Python optimized mode.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 4 Sep 2026
- **Also known as:** GHSA-q8gq-377p-jq3r, MINI-7p69-f6m2-cc4r, MINI-jx2c-gf52-2pw6, MINI-rjgp-hvfc-vvgm, PYSEC-2026-2300

## What is CVE-2026-41523?

CVE-2026-41523 is a high-severity code injection vulnerability in Vllm Vllm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.0, an assert-based security check in vLLM's activation function loading allows any unauthenticated attacker to achieve arbitrary code execution on the server by publishing a malicious HuggingFace model, when vLLM runs in Python optimized mode (python -O or PYTHONOPTIMIZE=1). This vulnerability is fixed in 0.22.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2026-41523?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.22.0 |
| `vllm` | PyPI | All versions | 0.22.0 |
| `vllm` | PyPI | All versions | 0.22.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-41523?

Upgrade vllm to 0.22.0 or later.

## Is CVE-2026-41523 being exploited?

There is no known exploitation of CVE-2026-41523 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41523 and fix it if it is affected.

What it is: CVE-2026-41523 is a high-severity code injection vulnerability in Vllm Vllm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-41523 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.22.0
- vllm (PyPI): affected all versions; fixed in 0.22.0
- vllm (PyPI): affected all versions; fixed in 0.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41523/ (Markdown: https://insights.sbomify.com/CVE-2026-41523/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41523
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41523
- OSV: https://osv.dev/vulnerability/CVE-2026-41523

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41523/
Summaries are generated and may contain mistakes; the official description above is the record.
