{"answers":{"affected":"2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-core-rest.","exploited":"There is no known exploitation of CVE-2026-41573 in the wild and no public exploit code.","fix":"Upgrade org.openidentityplatform.openam:openam-core-rest to 16.1.1 or later.","what":"CVE-2026-41573 is a high-severity vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41573 and fix it if it is affected.\n\nWhat it is: CVE-2026-41573 is a high-severity vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-41573 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.openidentityplatform.openam:openam-core-rest (Maven): affected all versions; fixed in 16.1.1\n- org.openidentityplatform.openam:openam-core-rest (Maven): affected all versions; fixed in 16.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41573/ (Markdown: https://insights.sbomify.com/CVE-2026-41573/index.md)","id":"CVE-2026-41573","markdown":"https://insights.sbomify.com/CVE-2026-41573/index.md","name":"CVE-2026-41573","record":{"aliases":["GHSA-2vg8-q4c2-5cw3","UBUNTU-CVE-2026-41573"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenAM access management","requires_auth":"low_privilege","summary":"Authenticated attackers can inject LDAP metacharacters via the _queryId parameter to enumerate users and perform blind LDAP injection in OpenAM.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-90","name":"Improper Neutralization of Special Elements used in an LDAP Query"}],"description":"Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, IdentityResourceV1.queryCollection() passes the _queryId parameter from /json/{realm}/users to CrestQuery with escapeQueryId disabled, bypassing protection added for CVE-2021-29156. The unescaped value reaches DJLDAPv3Repo.getFilter(), where it is concatenated into an LDAP filter, allowing an authenticated attacker to inject LDAP metacharacters for user enumeration and blind LDAP injection. This issue is fixed in version 16.1.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenAM LDAP Injection via `_queryId` Parameter","id":"CVE-2026-41573","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"other","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Nhost Vulnerable to Account Takeover via OAuth Email Verification Bypass","id":"CVE-2026-41574"},"packages":[{"ecosystem":"Maven","fixed":["16.1.1"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-core-rest","purl":null,"source":"GHSA-2vg8-q4c2-5cw3"},{"ecosystem":"Maven","fixed":["16.1.1"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-core-rest","purl":"pkg:maven/org.openidentityplatform.openam/openam-core-rest","source":"GHSA-2vg8-q4c2-5cw3"}],"prev":{"headline":"Note Mark: Unauthenticated read of notes and assets in soft-deleted public books","id":"CVE-2026-41572"},"products":["OpenAM"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-15","vendors":["OpenIdentityPlatform"]},"summary":"Authenticated attackers can inject LDAP metacharacters via the _queryId parameter to enumerate users and perform blind LDAP injection in OpenAM.","url":"https://insights.sbomify.com/CVE-2026-41573/"}