CVE-2026-41575 th30d4y/IP: DOM-Based Cross-Site Scripting (XSS) Vulnerability

Medium 6.1 Published Updated

Attackers can execute arbitrary JavaScript in users' browsers via unsanitized input in the IP Reputation Checker application.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-41575?

CVE-2026-41575 is a medium-severity cross-site scripting vulnerability in th30d4y IP, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

In th30d4y/IP from version 1.0.1 to before version 2.0.1, a DOM-Based Cross-Site Scripting (XSS) vulnerability was identified in an IP Reputation Checker application. Unsanitized user input was directly rendered in the browser, allowing attackers to execute arbitrary JavaScript. This issue has been patched in version 2.0.1.

Weakness: CWE-80, CWE-79

Which versions are affected by CVE-2026-41575?

It affects 1 product.

Products include Th30d4y W4nn4d13\/Ip.

How do I fix CVE-2026-41575?

No fix has been published for CVE-2026-41575 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-41575 being exploited?

There is no known exploitation of CVE-2026-41575 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-j7wv-7j97-9qh9.

Is CVE-2026-41575 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free