# CVE-2026-41575: th30d4y/IP: DOM-Based Cross-Site Scripting (XSS) Vulnerability

> Attackers can execute arbitrary JavaScript in users' browsers via unsanitized input in the IP Reputation Checker application.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-j7wv-7j97-9qh9

## What is CVE-2026-41575?

CVE-2026-41575 is a medium-severity cross-site scripting vulnerability in th30d4y IP, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In th30d4y/IP from version 1.0.1 to before version 2.0.1, a DOM-Based Cross-Site Scripting (XSS) vulnerability was identified in an IP Reputation Checker application. Unsanitized user input was directly rendered in the browser, allowing attackers to execute arbitrary JavaScript. This issue has been patched in version 2.0.1.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-41575?

It affects 1 product.


Products: Th30d4y W4nn4d13\/Ip.

## How do I fix CVE-2026-41575?

No fix has been published for CVE-2026-41575 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-41575 being exploited?

There is no known exploitation of CVE-2026-41575 in the wild and no public exploit code.

Public exploit code:

- https://github.com/krrazee/CVE-2026-41575 (github_poc): https://github.com/krrazee/CVE-2026-41575

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41575 and fix it if it is affected.

What it is: CVE-2026-41575 is a medium-severity cross-site scripting vulnerability in th30d4y IP, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-41575 in the wild and no public exploit code.

Affected product: th30d4y IP. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41575/ (Markdown: https://insights.sbomify.com/CVE-2026-41575/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41575
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41575
- OSV: https://osv.dev/vulnerability/CVE-2026-41575

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41575/
Summaries are generated and may contain mistakes; the official description above is the record.
