CVE-2026-41581 Frappe Vulnerable to Possible SQL Injection via get_blog_list

Medium 6.9 Published Updated

Attackers can execute arbitrary SQL commands via the get_blog_list function in Frappe, potentially reading or modifying database contents.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-41581?

CVE-2026-41581 is a medium-severity SQL injection vulnerability in frappe, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Frappe is a full-stack web application framework. Prior to versions 15.106.0 and 16.16.0, there is a possible SQL Injection via get_blog_list. This issue has been patched in versions 15.106.0 and 16.16.0.

Weakness: CWE-89

Which versions are affected by CVE-2026-41581?

How do I fix CVE-2026-41581?

No fix has been published for CVE-2026-41581 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2026-41581 being exploited?

There is no known exploitation of CVE-2026-41581 in the wild and no public exploit code.

Sources

Also known as GHSA-h9hf-57r4-cm65.

Is CVE-2026-41581 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free