# CVE-2026-41582: countly-server: Unauthenticated Path Traversal via Public Image and Screenshot Routes Leads to Read Internal Files

> Unauthenticated attackers can read arbitrary server files via path traversal in public image routes on local filesystem deployments.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** GHSA-fqgp-6rm9-8696

## What is CVE-2026-41582?

CVE-2026-41582 is a high-severity path traversal vulnerability in countly-server, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

countly-server is the server-side part of Countly, a product analytics solution. Prior to 24.05.50 and 25.03.44, public image and screenshot routes implemented in frontend/express/app.js, plugins/star-rating/frontend/app.js, and plugins/dashboards/frontend/app.js concatenate attacker-controlled wildcard paths without containment validation. On deployments using the local filesystem backend, an unauthenticated request can traverse outside the intended asset directories and reach getStats or getStream in api/utils/countlyFs.js, allowing arbitrary readable server files to be disclosed. The affected routes include /appimages/*, /memberimages/*, */screenshots/*, /star-rating/images/*, and /dashboards/images/screenshots/*. This issue is fixed in versions 24.05.50 and 25.03.44.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-41582?


## How do I fix CVE-2026-41582?

No fix has been published for CVE-2026-41582 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-41582 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41582 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41582 and fix it if it is affected.

What it is: CVE-2026-41582 is a high-severity path traversal vulnerability in countly-server, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41582 exists.

Affected product: countly-server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41582/ (Markdown: https://insights.sbomify.com/CVE-2026-41582/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41582
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41582
- OSV: https://osv.dev/vulnerability/CVE-2026-41582

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41582/
Summaries are generated and may contain mistakes; the official description above is the record.
