CVE-2026-41585 ZEBRA: Denial of Service via Interrupted JSON-RPC Requests from Authenticated Clients
An authenticated RPC client can crash the Zcash node by disconnecting during JSON-RPC requests, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41585?
CVE-2026-41585 is a medium-severity denial of service vulnerability in ZcashFoundation zebra, published on 8 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
ZEBRA is a Zcash node written entirely in Rust. From zebrad versions 2.2.0 to before 4.3.1 and from zebra-rpc versions 1.0.0-beta.45 to before 6.0.2, a vulnerability in Zebra's JSON-RPC HTTP middleware allows an authenticated RPC client to cause a Zebra node to crash by disconnecting before the request body is fully received. The node treats the failure to read the HTTP request body as an unrecoverable error and aborts the process instead of returning an error response. This issue has been patched in zebrad version 4.3.1 and zebra-rpc version 6.0.2.
Which versions are affected by CVE-2026-41585?
4 open source packages ship an affected version, including zebra-rpc and zebrad. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
zebra-rpc crates.io | From 1.0.0-beta.45 | 6.0.2 |
zebra-rpc crates.io | From 1.0.0-beta.45 | 6.0.2 |
zebrad crates.io | From 2.2.0 | 4.3.1 |
zebrad crates.io | From 2.2.0 | 4.3.1 |
Products include Zfnd Zebra-Rpc, Zfnd Zebrad.
How do I fix CVE-2026-41585?
Upgrade zebra-rpc to 6.0.2 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-41585 being exploited?
There is no known exploitation of CVE-2026-41585 in the wild and no public exploit code.
Sources
Also known as GHSA-29x4-r6jv-ff4w.