# CVE-2026-41586: ObjectInputStream.readObject() without ObjectInputFilter in fabric-sdk-java allows Java deserialization RCE

> Attackers can execute arbitrary code via unsafe Java deserialization in the Hyperledger Fabric SDK when processing untrusted data.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** BIT-hyperledger-fabric-orderer-2026-41586, BIT-hyperledger-fabric-peer-2026-41586, BIT-hyperledger-fabric-tools-2026-41586, GHSA-prf8-cf2x-rhx7

## What is CVE-2026-41586?

CVE-2026-41586 is a critical unsafe deserialization vulnerability in hyperledger fabric, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. From versions 1.0.0 to 2.2.26, Channel.java implements readObject() and exposes deSerializeChannel() which call ObjectInputStream.readObject() on untrusted byte arrays without configuring an ObjectInputFilter. This is a classic Java deserialization RCE pattern. At time of publication, there are no publicly available patches.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-41586?

5 open source packages ship an affected version, including org.hyperledger.fabric-sdk-java:fabric-sdk-java, hyperledger-fabric-orderer and hyperledger-fabric-peer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.hyperledger.fabric-sdk-java:fabric-sdk-java` | Maven | From 1.0.0 to 2.2.26 | None |
| `org.hyperledger.fabric-sdk-java:fabric-sdk-java` | Maven | From 1.0.0 to 2.2.26 | None |
| `hyperledger-fabric-orderer` | Bitnami | From 1.0.0 | 2.5.9 |
| `hyperledger-fabric-peer` | Bitnami | From 1.0.0 | 2.5.9 |
| `hyperledger-fabric-tools` | Bitnami | From 1.0.0 | 2.5.9 |

Products: Hyperledger Fabric.

## How do I fix CVE-2026-41586?

No fix published yet.

## Is CVE-2026-41586 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41586 exists.

## Other vulnerabilities in hyperledger fabric

- [CVE-2022-45196](https://insights.sbomify.com/CVE-2022-45196/): Denial of service in n/a (high 7.5)
- [CVE-2022-31121](https://insights.sbomify.com/CVE-2022-31121/): Improper Input Validation in fabric hyperledger (high 7.5)
- [CVE-2023-46132](https://insights.sbomify.com/CVE-2023-46132/): Crosslinking transaction attack in hyperledger/fabric (high 7.1)
- [CVE-2022-36023](https://insights.sbomify.com/CVE-2022-36023/): Remote denial of service in Hyperledger Fabric Gateway (high 7.0)
- [CVE-2024-45244](https://insights.sbomify.com/CVE-2024-45244/): Hyperledger Fabric does not verify request has a timestamp within the expected time window (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41586 and fix it if it is affected.

What it is: CVE-2026-41586 is a critical unsafe deserialization vulnerability in hyperledger fabric, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41586 exists.

Affected packages and fixed versions:
- org.hyperledger.fabric-sdk-java:fabric-sdk-java (Maven): affected from 1.0.0 up to 2.2.26; no fix listed
- org.hyperledger.fabric-sdk-java:fabric-sdk-java (Maven): affected from 1.0.0 up to 2.2.26; no fix listed
- hyperledger-fabric-orderer (Bitnami): affected from 1.0.0; fixed in 2.5.9
- hyperledger-fabric-peer (Bitnami): affected from 1.0.0; fixed in 2.5.9
- hyperledger-fabric-tools (Bitnami): affected from 1.0.0; fixed in 2.5.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41586/ (Markdown: https://insights.sbomify.com/CVE-2026-41586/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41586
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41586
- OSV: https://osv.dev/vulnerability/CVE-2026-41586

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41586/
Summaries are generated and may contain mistakes; the official description above is the record.
