{"answers":{"affected":"2 open source packages ship an affected version, including ci4-cms-erp/ci4ms.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41587 exists.","fix":"Upgrade ci4-cms-erp/ci4ms to 0.31.7.0 or later.","what":"CVE-2026-41587 is a high-severity vulnerability in ci4-cms-erp ci4ms, published on 7 May 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41587 and fix it if it is affected.\n\nWhat it is: CVE-2026-41587 is a high-severity vulnerability in ci4-cms-erp ci4ms, published on 7 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41587 exists.\n\nAffected packages and fixed versions:\n- ci4-cms-erp/ci4ms (Packagist): affected from 0.26.0.0; fixed in 0.31.7.0\n- ci4-cms-erp/ci4ms (Packagist): affected from 0.26.0.0; fixed in 0.31.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41587/ (Markdown: https://insights.sbomify.com/CVE-2026-41587/index.md)","id":"CVE-2026-41587","markdown":"https://insights.sbomify.com/CVE-2026-41587/index.md","name":"CVE-2026-41587","record":{"aliases":["GHSA-fw49-9xq4-gmx6"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"CodeIgniter CMS skeleton","requires_auth":"high_privilege","summary":"Authenticated users can upload malicious PHP files via theme installation to achieve remote code execution on the server.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. From version 0.26.0.0 to before version 0.31.7.0, a theme upload feature allows any authenticated backend user with theme-upload permission to achieve remote code execution (RCE) by uploading a crafted ZIP file. PHP files inside the ZIP are installed into the web-accessible public/ directory with no extension or content filtering, making them directly executable via HTTP. This issue has been patched in version 0.31.7.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"CI4MS: Unrestricted PHP File Upload via Theme Installation Leads to Authenticated Remote Code Execution","id":"CVE-2026-41587","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"file_upload","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"RELATE: Timing Attack Vulnerability in course/auth.py — check_sign_in_key()","id":"CVE-2026-41588"},"packages":[{"ecosystem":"Packagist","fixed":["0.31.7.0"],"introduced":["0.26.0.0"],"last_affected":[],"package":"ci4-cms-erp/ci4ms","purl":null,"source":"GHSA-fw49-9xq4-gmx6"},{"ecosystem":"Packagist","fixed":["0.31.7.0"],"introduced":["0.26.0.0"],"last_affected":[],"package":"ci4-cms-erp/ci4ms","purl":"pkg:composer/ci4-cms-erp/ci4ms","source":"GHSA-fw49-9xq4-gmx6"}],"prev":{"headline":"ObjectInputStream.readObject() without ObjectInputFilter in fabric-sdk-java allows Java deserialization RCE","id":"CVE-2026-41586"},"products":["ci4ms"],"published":"2026-05-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-07","vendors":["ci4-cms-erp"]},"summary":"Authenticated users can upload malicious PHP files via theme installation to achieve remote code execution on the server.","url":"https://insights.sbomify.com/CVE-2026-41587/"}