# CVE-2026-41587: CI4MS: Unrestricted PHP File Upload via Theme Installation Leads to Authenticated Remote Code Execution

> Authenticated users can upload malicious PHP files via theme installation to achieve remote code execution on the server.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-fw49-9xq4-gmx6

## What is CVE-2026-41587?

CVE-2026-41587 is a high-severity vulnerability in ci4-cms-erp ci4ms, published on 7 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. From version 0.26.0.0 to before version 0.31.7.0, a theme upload feature allows any authenticated backend user with theme-upload permission to achieve remote code execution (RCE) by uploading a crafted ZIP file. PHP files inside the ZIP are installed into the web-accessible public/ directory with no extension or content filtering, making them directly executable via HTTP. This issue has been patched in version 0.31.7.0.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-41587?

2 open source packages ship an affected version, including ci4-cms-erp/ci4ms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ci4-cms-erp/ci4ms` | Packagist | From 0.26.0.0 | 0.31.7.0 |
| `ci4-cms-erp/ci4ms` | Packagist | From 0.26.0.0 | 0.31.7.0 |

## How do I fix CVE-2026-41587?

Upgrade ci4-cms-erp/ci4ms to 0.31.7.0 or later.

## Is CVE-2026-41587 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41587 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41587 and fix it if it is affected.

What it is: CVE-2026-41587 is a high-severity vulnerability in ci4-cms-erp ci4ms, published on 7 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41587 exists.

Affected packages and fixed versions:
- ci4-cms-erp/ci4ms (Packagist): affected from 0.26.0.0; fixed in 0.31.7.0
- ci4-cms-erp/ci4ms (Packagist): affected from 0.26.0.0; fixed in 0.31.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41587/ (Markdown: https://insights.sbomify.com/CVE-2026-41587/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41587
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41587
- OSV: https://osv.dev/vulnerability/CVE-2026-41587

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41587/
Summaries are generated and may contain mistakes; the official description above is the record.
