CVE-2026-41602 Apache Thrift: Go TFramedTransport uint32 overflow

High 7.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-41602?

CVE-2026-41602 is a high-severity vulnerability in Apache Thrift, published on 28 Apr 2026.

Official description

Integer Overflow or Wraparound vulnerability in Apache Thrift TFramedTransport Go language implementation

This issue affects Apache Thrift: before 0.23.0.

Users are recommended to upgrade to version 0.23.0, which fixes the issue.

Weakness: CWE-190

Which versions are affected by CVE-2026-41602?

3 open source packages ship an affected version, including github.com/apache/thrift and thrift. It affects 1 product.

PackageAffectedFixed in
github.com/apache/thrift GoAll versions0.23.0
github.com/apache/thrift GoAll versions0.23.0
thrift BitnamiAll versions0.23.0
Linux distribution packages (2)
amazon-cloudwatch-agent openSUSE:TumbleweedAll versions1.300066.1-1.1
grafana openSUSE:TumbleweedAll versions11.6.14+security01-3.1

Products include Apache Thrift.

How do I fix CVE-2026-41602?

Upgrade github.com/apache/thrift to 0.23.0 or later.

Is CVE-2026-41602 being exploited?

There is no known exploitation of CVE-2026-41602 in the wild and no public exploit code.

Sources

Also known as AZL-85017, AZL-85220, AZL-85223, AZL-85226, AZL-85229, AZL-85292 and 84 more.

Is CVE-2026-41602 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free