CVE-2026-41606 Apache Thrift: c_glib dispatch stack overflow

Medium 5.3 Published Updated

An attacker can cause a stack overflow and denial of service in applications using the Apache Thrift c_glib library via uncontrolled recursion.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41606?

CVE-2026-41606 is a medium-severity denial of service vulnerability in Apache Thrift, published on 28 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Uncontrolled Recursion vulnerability in Apache Thrift.

This issue affects Apache Thrift: before 0.23.0.

Users are recommended to upgrade to version 0.23.0, which fixes the issue.

Weakness: CWE-606, CWE-674

Which versions are affected by CVE-2026-41606?

1 open source package ship an affected version, including thrift. It affects 1 product.

PackageAffectedFixed in
thrift BitnamiAll versions0.23.0
Linux distribution packages (1)
grafana openSUSE:TumbleweedAll versions12.4.5-5.1

Products include Apache Thrift.

How do I fix CVE-2026-41606?

Upgrade thrift to 0.23.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-41606 being exploited?

There is no known exploitation of CVE-2026-41606 in the wild and no public exploit code.

Sources

Also known as AZL-85029, BIT-thrift-2026-41606, DEBIAN-CVE-2026-41606, ECHO-13f5-3eee-3121, GHSA-h5hj-56h4-rwcp, UBUNTU-CVE-2026-41606 and 1 more.

Is CVE-2026-41606 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free