CVE-2026-41607 Apache Thrift: C++ JSON OOB read

Medium 6.5 Published Updated

An out-of-bounds read in the C++ JSON parser of Apache Thrift allows attackers to cause denial of service or disclose sensitive memory contents.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41607?

CVE-2026-41607 is a medium-severity memory corruption vulnerability in Apache Thrift, published on 28 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Out-of-bounds Read vulnerability in Apache Thrift.

This issue affects Apache Thrift: before 0.23.0.

Users are recommended to upgrade to version 0.23.0, which fixes the issue.

Weakness: CWE-125

Which versions are affected by CVE-2026-41607?

1 open source package ship an affected version, including thrift. It affects 1 product.

PackageAffectedFixed in
thrift BitnamiAll versions0.23.0
Linux distribution packages (1)
grafana openSUSE:TumbleweedAll versions11.6.14+security04-4.1

Products include Apache Thrift.

How do I fix CVE-2026-41607?

Upgrade thrift to 0.23.0 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-41607 being exploited?

There is no known exploitation of CVE-2026-41607 in the wild and no public exploit code.

Sources

Also known as AZL-85032, BIT-thrift-2026-41607, DEBIAN-CVE-2026-41607, ECHO-0ef1-2235-bd97, GHSA-7gqw-825c-3842, UBUNTU-CVE-2026-41607 and 1 more.

Is CVE-2026-41607 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free