# CVE-2026-41641: NocoBase Vulnerable to SQL Validation Bypass via `sqlCollection:update` Missing `checkSQL` Call

> Attackers with collection permissions can bypass SQL validation to execute arbitrary SQL and exfiltrate data via the update endpoint.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-wrwh-c28m-9jjh

## What is CVE-2026-41641?

CVE-2026-41641 is a high-severity SQL injection vulnerability in nocobase, published on 7 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

NocoBase is an AI-powered no-code/low-code platform for building business applications and enterprise solutions. Prior to version 2.0.39, the checkSQL() validation function that blocks dangerous SQL keywords (e.g., pg_read_file, LOAD_FILE, dblink) is applied on the collections:create and sqlCollection:execute endpoints but is entirely missing on the sqlCollection:update endpoint. An attacker with collection management permissions can create a SQL collection with benign SQL, then update it with arbitrary SQL that bypasses all validation, and query the collection to execute the injected SQL and exfiltrate data. This issue has been patched in version 2.0.39.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-41641?

2 open source packages ship an affected version, including @nocobase/plugin-collection-sql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@nocobase/plugin-collection-sql` | npm | All versions | 2.0.39 |
| `@nocobase/plugin-collection-sql` | npm | All versions | 2.0.39 |

Products: Nocobase Nocobase.

## How do I fix CVE-2026-41641?

Upgrade @nocobase/plugin-collection-sql to 2.0.39 or later.

## Is CVE-2026-41641 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41641 exists.

Public exploit code:

- NocoBase - SQL Injection (nuclei): http/cves/2026/CVE-2026-41641.yaml

## Other vulnerabilities in nocobase

- [CVE-2026-34156](https://insights.sbomify.com/CVE-2026-34156/): NocoBase Affected by Sandbox Escape to RCE via console._stdout Prototype Chain Traversal in Workflow Script Node (critical 10.0)
- [CVE-2026-34825](https://insights.sbomify.com/CVE-2026-34825/): NocoBase Has SQL Injection via template variable substitution in workflow SQL node (high 8.5)
- [CVE-2026-41640](https://insights.sbomify.com/CVE-2026-41640/): NocoBase Vulnerable to SQL Injection via String Concatenation in Recursive Eager Loading (high 7.5)
- [CVE-2026-40346](https://insights.sbomify.com/CVE-2026-40346/): NocoBase has SSRF in Workflow HTTP Request and Custom Request Plugins (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41641 and fix it if it is affected.

What it is: CVE-2026-41641 is a high-severity SQL injection vulnerability in nocobase, published on 7 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41641 exists.

Affected packages and fixed versions:
- @nocobase/plugin-collection-sql (npm): affected all versions; fixed in 2.0.39
- @nocobase/plugin-collection-sql (npm): affected all versions; fixed in 2.0.39

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41641/ (Markdown: https://insights.sbomify.com/CVE-2026-41641/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41641
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41641
- OSV: https://osv.dev/vulnerability/CVE-2026-41641

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41641/
Summaries are generated and may contain mistakes; the official description above is the record.
