{"answers":{"affected":"3 open source packages ship an affected version, including github.com/osrg/gobgp/v4. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41643 exists.","fix":"Upgrade github.com/osrg/gobgp/v4 to 4.3.0 or later.","what":"CVE-2026-41643 is a high-severity denial of service vulnerability in osrg gobgp, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41643 and fix it if it is affected.\n\nWhat it is: CVE-2026-41643 is a high-severity denial of service vulnerability in osrg gobgp, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41643 exists.\n\nAffected packages and fixed versions:\n- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.3.0\n- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.3.0\n- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41643/ (Markdown: https://insights.sbomify.com/CVE-2026-41643/index.md)","id":"CVE-2026-41643","markdown":"https://insights.sbomify.com/CVE-2026-41643/index.md","name":"CVE-2026-41643","record":{"aliases":["DEBIAN-CVE-2026-41643","GHSA-8rxh-r2p6-7f2q","GO-2026-5266","UBUNTU-CVE-2026-41643"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"BGP routing software","requires_auth":"none","summary":"Remote attackers can cause a denial of service in GoBGP by sending malformed BGP UPDATE messages that trigger a panic.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"gobgp","vendor":"osrg"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-129","name":"Improper Validation of Array Index"}],"description":"GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language. Prior to version 4.3.0, a remote Denial of Service (DoS) vulnerability exists in GoBGP where a malformed BGP UPDATE message can trigger a runtime error: index out of range panic. This occurs during the processing of 4-byte AS attributes when the message structure causes an internal slice index shift that is not properly handled. This issue has been patched in version 4.3.0.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"GoBGP: Remote Denial of Service (Panic) in UpdatePathAttrs4ByteAs via Malformed BGP UPDATE","id":"CVE-2026-41643","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"monetr is vulnerable to server-side request forgery in Lunch Flow link creation and refresh","id":"CVE-2026-41644"},"packages":[{"ecosystem":"Go","fixed":["4.3.0"],"introduced":["0"],"last_affected":[],"package":"github.com/osrg/gobgp/v4","purl":null,"source":"GHSA-8rxh-r2p6-7f2q"},{"ecosystem":"Go","fixed":["4.3.0"],"introduced":["0"],"last_affected":[],"package":"github.com/osrg/gobgp/v4","purl":"pkg:golang/github.com/osrg/gobgp/v4","source":"GHSA-8rxh-r2p6-7f2q"},{"ecosystem":"Go","fixed":["4.3.0"],"introduced":["0"],"last_affected":[],"package":"github.com/osrg/gobgp/v4","purl":"pkg:golang/github.com/osrg/gobgp/v4","source":"GO-2026-5266"}],"prev":{"headline":"GoBGP: Remote Denial of Service (Panic) via Malformed Well-known Path Attribute","id":"CVE-2026-41642"},"products":["gobgp"],"published":"2026-05-07","related":[{"cvss_score":8.6,"headline":"GoBGP panics due to a zero value for softwareVersionLen","id":"CVE-2025-43971","kev_date_added":null,"published":"2025-04-21"},{"cvss_score":7.5,"headline":"GoBGP: Remote Denial of Service (Panic) via Malformed Well-known Path Attribute","id":"CVE-2026-41642","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":7.5,"headline":"GoBGP: Panic in AdjRib.Update via malformed BGP Update message (Nil Pointer Dereference)","id":"CVE-2026-42285","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":7.5,"headline":"GoBGP has an out-of-bounds read in the ParseIP6Extended function","id":"CVE-2026-37461","kev_date_added":null,"published":"2026-05-04"},{"cvss_score":7.5,"headline":"GoBGP vulnerable to a denial of service via the NEXT_HOP path attribute","id":"CVE-2026-30405","kev_date_added":null,"published":"2026-03-16"},{"cvss_score":6.9,"headline":"osrg GoBGP SRv6 L3 Service prefix_sid.go SRv6L3ServiceAttribute.DecodeFromBytes denial of service","id":"CVE-2026-7734","kev_date_added":null,"published":"2026-05-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-07","vendors":["osrg"]},"summary":"Remote attackers can cause a denial of service in GoBGP by sending malformed BGP UPDATE messages that trigger a panic.","url":"https://insights.sbomify.com/CVE-2026-41643/"}