# CVE-2026-41643: GoBGP: Remote Denial of Service (Panic) in UpdatePathAttrs4ByteAs via Malformed BGP UPDATE

> Remote attackers can cause a denial of service in GoBGP by sending malformed BGP UPDATE messages that trigger a panic.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** DEBIAN-CVE-2026-41643, GHSA-8rxh-r2p6-7f2q, GO-2026-5266, UBUNTU-CVE-2026-41643

## What is CVE-2026-41643?

CVE-2026-41643 is a high-severity denial of service vulnerability in osrg gobgp, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language. Prior to version 4.3.0, a remote Denial of Service (DoS) vulnerability exists in GoBGP where a malformed BGP UPDATE message can trigger a runtime error: index out of range panic. This occurs during the processing of 4-byte AS attributes when the message structure causes an internal slice index shift that is not properly handled. This issue has been patched in version 4.3.0.

Weakness: CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-41643?

3 open source packages ship an affected version, including github.com/osrg/gobgp/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/osrg/gobgp/v4` | Go | All versions | 4.3.0 |
| `github.com/osrg/gobgp/v4` | Go | All versions | 4.3.0 |
| `github.com/osrg/gobgp/v4` | Go | All versions | 4.3.0 |

Products: Osrg Gobgp.

## How do I fix CVE-2026-41643?

Upgrade github.com/osrg/gobgp/v4 to 4.3.0 or later.

## Is CVE-2026-41643 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41643 exists.

## Other vulnerabilities in osrg gobgp

- [CVE-2025-43971](https://insights.sbomify.com/CVE-2025-43971/): GoBGP panics due to a zero value for softwareVersionLen (high 8.6)
- [CVE-2026-41642](https://insights.sbomify.com/CVE-2026-41642/): GoBGP: Remote Denial of Service (Panic) via Malformed Well-known Path Attribute (high 7.5)
- [CVE-2026-42285](https://insights.sbomify.com/CVE-2026-42285/): GoBGP: Panic in AdjRib.Update via malformed BGP Update message (Nil Pointer Dereference) (high 7.5)
- [CVE-2026-37461](https://insights.sbomify.com/CVE-2026-37461/): GoBGP has an out-of-bounds read in the ParseIP6Extended function (high 7.5)
- [CVE-2026-30405](https://insights.sbomify.com/CVE-2026-30405/): GoBGP vulnerable to a denial of service via the NEXT_HOP path attribute (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41643 and fix it if it is affected.

What it is: CVE-2026-41643 is a high-severity denial of service vulnerability in osrg gobgp, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41643 exists.

Affected packages and fixed versions:
- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.3.0
- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.3.0
- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41643/ (Markdown: https://insights.sbomify.com/CVE-2026-41643/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41643
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41643
- OSV: https://osv.dev/vulnerability/CVE-2026-41643

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41643/
Summaries are generated and may contain mistakes; the official description above is the record.
