# CVE-2026-41648: Incus: Unbounded YAML Metadata Decode via Parsing

> An authenticated user can cause a denial of service by uploading a crafted image or backup tarball with unbounded YAML metadata.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** DEBIAN-CVE-2026-41648, GHSA-67wx-r9xr-x75x, GO-2026-5168, UBUNTU-CVE-2026-41648

## What is CVE-2026-41648?

CVE-2026-41648 is a medium-severity denial of service vulnerability in lxc incus, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incus is a system container and virtual machine manager. Prior to version 7.0.0, user provided image and backup tarballs would be unpacked and YAML files parsed without any size restrictions. This was making it easy for an authenticated user to provide a crafted image or backup tarball that when parsed by Incus would lead to a very large YAML document being loaded into memory, potentially causing the entire server to run out of memory. This issue has been patched in version 7.0.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-41648?

4 open source packages ship an affected version, including github.com/lxc/incus/v6/cmd/incusd, github.com/lxc/incus and github.com/lxc/incus/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lxc/incus/v6/cmd/incusd` | Go | All versions to 6.23.0 | None |
| `github.com/lxc/incus/v6/cmd/incusd` | Go | All versions to 6.23.0 | None |
| `github.com/lxc/incus` | Go | All versions | None |
| `github.com/lxc/incus/v6` | Go | All versions | None |

Products: Linuxcontainers Incus.

## How do I fix CVE-2026-41648?

Upgrade to a fixed version.

## Is CVE-2026-41648 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41648 exists.

## Other vulnerabilities in lxc incus

- [CVE-2026-33897](https://insights.sbomify.com/CVE-2026-33897/): Incus vulnerable to arbitrary file read and write through pongo templates (critical 10.0)
- [CVE-2026-33945](https://insights.sbomify.com/CVE-2026-33945/): Abitrary file write through systemd-creds option (critical 10.0)
- [CVE-2026-33898](https://insights.sbomify.com/CVE-2026-33898/): Local Incus UI web server vulnerable to nuthentication bypass (high 8.8)
- [CVE-2026-23953](https://insights.sbomify.com/CVE-2026-23953/): Incus container environment configuration newline injection (high 8.7)
- [CVE-2026-23954](https://insights.sbomify.com/CVE-2026-23954/): Incus container image templating arbitrary host file read and write (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41648 and fix it if it is affected.

What it is: CVE-2026-41648 is a medium-severity denial of service vulnerability in lxc incus, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41648 exists.

Affected packages and fixed versions:
- github.com/lxc/incus/v6/cmd/incusd (Go): affected all versions up to 6.23.0; no fix listed
- github.com/lxc/incus/v6/cmd/incusd (Go): affected all versions up to 6.23.0; no fix listed
- github.com/lxc/incus (Go): affected all versions; no fix listed
- github.com/lxc/incus/v6 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41648/ (Markdown: https://insights.sbomify.com/CVE-2026-41648/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41648
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41648
- OSV: https://osv.dev/vulnerability/CVE-2026-41648

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41648/
Summaries are generated and may contain mistakes; the official description above is the record.
