# CVE-2026-41650: fast-xml-parser XMLBuilder: XML Comment and CDATA Injection via Unescaped Delimiters

> Attackers can inject malicious XML comments or CDATA sections via unescaped delimiters, potentially leading to XSS or data manipulation in applications using fast-xml-parser.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** CLEANSTART-2026-CK33786, CLEANSTART-2026-NG55070, CLSA-2026-1777336754, CLSA-2026-1786525960, DEBIAN-CVE-2026-41650, ECHO-c4c5-a42c-d4a0, GHSA-gh4j-gqv2-49f6, MINI-346f-63mg-9972, MINI-34mg-j2m8-gf2w, MINI-3gj4-397q-r472, MINI-6rq5-r6ch-6f7m, MINI-74fm-p2qp-m8x7, MINI-7fcc-v7rg-3cmg, MINI-8m7g-fq2w-69w8, MINI-972j-f2mh-cc73, MINI-cm88-349c-hjc9, MINI-g7rx-fh3f-vpmx, MINI-hvmq-jgj4-wjww, MINI-jr4m-v73f-wm6x, MINI-pgv7-c8x8-8vrg, MINI-pm72-h8xc-jf24, MINI-r54c-q577-9q3p, MINI-rffm-3hgj-q33p, MINI-w2ch-fj3r-wq5f, MINI-xx2m-j3rw-88cp, ROOT-APP-NPM-CVE-2026-41650, UBUNTU-CVE-2026-41650

## What is CVE-2026-41650?

CVE-2026-41650 is a medium-severity cross-site scripting vulnerability in NaturalIntelligence fast-xml-parser, published on 7 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

fast-xml-parser allows users to process XML from JS object without C/C++ based libraries or callbacks. Prior to version 5.7.0, XMLBuilder does not escape the "-->" sequence in comment content or the "]]>" sequence in CDATA sections when building XML from JavaScript objects. This allows XML injection when user-controlled data flows into comments or CDATA elements, leading to XSS, SOAP injection, or data manipulation. This issue has been patched in version 5.7.0.

Weakness: CWE-91 (XML Injection)

## Which versions are affected by CVE-2026-41650?

2 open source packages ship an affected version, including fast-xml-parser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-xml-parser` | npm | All versions | 5.7.0 |
| `fast-xml-parser` | npm | All versions | 5.7.0 |

Products: Naturalintelligence Fast-Xml-Parser.

## How do I fix CVE-2026-41650?

Upgrade fast-xml-parser to 5.7.0 or later.

## Is CVE-2026-41650 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41650 exists.

## Other vulnerabilities in NaturalIntelligence fast-xml-parser

- [CVE-2026-25896](https://insights.sbomify.com/CVE-2026-25896/): fast-xml-parser has an entity encoding bypass via regex injection in DOCTYPE entity names (critical 9.3)
- [CVE-2026-33036](https://insights.sbomify.com/CVE-2026-33036/): fast-xml-parser affected by numeric entity expansion bypassing all entity expansion limits (incomplete fix for CVE-2026-26278) (high 7.5)
- [CVE-2026-26278](https://insights.sbomify.com/CVE-2026-26278/): fast-xml-parser affected by DoS through entity expansion in DOCTYPE (no expansion limit) (high 7.5)
- [CVE-2026-25128](https://insights.sbomify.com/CVE-2026-25128/): fast-xml-parser has RangeError DoS Numeric Entities Bug (high 7.5)
- [CVE-2024-41818](https://insights.sbomify.com/CVE-2024-41818/): ReDOS at currency parsing fast-xml-parser (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41650 and fix it if it is affected.

What it is: CVE-2026-41650 is a medium-severity cross-site scripting vulnerability in NaturalIntelligence fast-xml-parser, published on 7 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41650 exists.

Affected packages and fixed versions:
- fast-xml-parser (npm): affected all versions; fixed in 5.7.0
- fast-xml-parser (npm): affected all versions; fixed in 5.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41650/ (Markdown: https://insights.sbomify.com/CVE-2026-41650/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41650
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41650
- OSV: https://osv.dev/vulnerability/CVE-2026-41650

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41650/
Summaries are generated and may contain mistakes; the official description above is the record.
