# CVE-2026-41657: Admidio: Cross-Organization Member Data Exposure via Permission Check Mismatch in contacts_data.php

> A user manager can bypass permission checks to view all user records across all organizations, exposing sensitive data.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-g8p8-94f2-28gr

## What is CVE-2026-41657?

CVE-2026-41657 is a medium-severity missing authorization vulnerability in admidio, published on 7 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Admidio is an open-source user management solution. Prior to version 5.0.9, the contacts_data.php endpoint uses a weaker permission check (isAdministratorUsers(), requiring only rol_edit_user=true) than the frontend UI (contacts.php) which correctly requires the stronger isAdministrator() (requiring rol_administrator=true) and the contacts_show_all system setting. A user manager who is not a full administrator can directly request contacts_data.php?mem_show_filter=3 to retrieve all user records across all organizations in the Admidio instance, bypassing multi-tenant organization isolation. This issue has been patched in version 5.0.9.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-41657?

2 open source packages ship an affected version, including admidio/admidio.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `admidio/admidio` | Packagist | All versions | 5.0.9 |
| `admidio/admidio` | Packagist | All versions | 5.0.9 |

## How do I fix CVE-2026-41657?

Upgrade admidio/admidio to 5.0.9 or later.

## Is CVE-2026-41657 being exploited?

There is no known exploitation of CVE-2026-41657 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41657 and fix it if it is affected.

What it is: CVE-2026-41657 is a medium-severity missing authorization vulnerability in admidio, published on 7 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41657 in the wild and no public exploit code.

Affected packages and fixed versions:
- admidio/admidio (Packagist): affected all versions; fixed in 5.0.9
- admidio/admidio (Packagist): affected all versions; fixed in 5.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41657/ (Markdown: https://insights.sbomify.com/CVE-2026-41657/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41657
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41657
- OSV: https://osv.dev/vulnerability/CVE-2026-41657

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41657/
Summaries are generated and may contain mistakes; the official description above is the record.
