# CVE-2026-41658: Admidio: Missing Authorization on Inventory Module Destructive Endpoints Allows Any Authenticated User to Delete Items

> Any authenticated user can delete inventory items because backend handlers lack authorization checks, allowing unauthorized data modification.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-xqv4-xm7h-52cv

## What is CVE-2026-41658?

CVE-2026-41658 is a medium-severity missing authorization vulnerability in admidio, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Admidio is an open-source user management solution. Prior to version 5.0.9, the Admidio inventory module enforces authorization for destructive operations (delete, retire, reinstate) only in the UI layer by conditionally rendering buttons. The backend POST handlers at modules/inventory.php for item_delete, item_retire, item_reinstate, item_picture_upload, item_picture_save, and item_picture_delete perform CSRF validation but never check whether the requesting user is an inventory administrator. Any authenticated user who can access the inventory module can permanently delete any inventory item and all its associated data. This issue has been patched in version 5.0.9.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-41658?

2 open source packages ship an affected version, including admidio/admidio.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `admidio/admidio` | Packagist | All versions | 5.0.9 |
| `admidio/admidio` | Packagist | All versions | 5.0.9 |

## How do I fix CVE-2026-41658?

Upgrade admidio/admidio to 5.0.9 or later.

## Is CVE-2026-41658 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41658 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41658 and fix it if it is affected.

What it is: CVE-2026-41658 is a medium-severity missing authorization vulnerability in admidio, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41658 exists.

Affected packages and fixed versions:
- admidio/admidio (Packagist): affected all versions; fixed in 5.0.9
- admidio/admidio (Packagist): affected all versions; fixed in 5.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41658/ (Markdown: https://insights.sbomify.com/CVE-2026-41658/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41658
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41658
- OSV: https://osv.dev/vulnerability/CVE-2026-41658

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41658/
Summaries are generated and may contain mistakes; the official description above is the record.
