# CVE-2026-41661: Admidio: Reflected XSS in msg_window.php via Square Bracket to HTML Tag Conversion

> Unauthenticated attackers can execute arbitrary JavaScript in user browsers via reflected XSS in Admidio's message window endpoint.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-gq27-fc8w-vcmp

## What is CVE-2026-41661?

CVE-2026-41661 is a medium-severity cross-site scripting vulnerability in admidio, published on 7 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Admidio is an open-source user management solution. Prior to version 5.0.9, an unauthenticated attacker can execute arbitrary JavaScript in any Admidio user's browser through a reflected XSS in system/msg_window.php. The endpoint passes user input through htmlspecialchars(), which does not encode square brackets. A subsequent call to Language::prepareTextPlaceholders() converts those brackets into HTML angle brackets, producing executable markup. This issue has been patched in version 5.0.9.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-41661?

2 open source packages ship an affected version, including admidio/admidio.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `admidio/admidio` | Packagist | All versions | 5.0.9 |
| `admidio/admidio` | Packagist | All versions | 5.0.9 |

## How do I fix CVE-2026-41661?

Upgrade admidio/admidio to 5.0.9 or later.

## Is CVE-2026-41661 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41661 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41661 and fix it if it is affected.

What it is: CVE-2026-41661 is a medium-severity cross-site scripting vulnerability in admidio, published on 7 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41661 exists.

Affected packages and fixed versions:
- admidio/admidio (Packagist): affected all versions; fixed in 5.0.9
- admidio/admidio (Packagist): affected all versions; fixed in 5.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41661/ (Markdown: https://insights.sbomify.com/CVE-2026-41661/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41661
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41661
- OSV: https://osv.dev/vulnerability/CVE-2026-41661

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41661/
Summaries are generated and may contain mistakes; the official description above is the record.
