# CVE-2026-41662: Admidio: Missing Minimum Administrator Check in Role Membership Removal

> Administrators can remove the last remaining admin, locking the system out of administrative access due to missing validation in role membership removal.

- **Severity:** Medium 5.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-c7xm-r6vj-8vg6

## What is CVE-2026-41662?

CVE-2026-41662 is a medium-severity vulnerability in admidio, published on 7 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Admidio is an open-source user management solution. Prior to version 5.0.9, Role::stopMembership() does not verify whether removing a user from the administrator role leaves zero administrators. The deprecated Membership::stopMembership() contains this safety check, but the current code path bypasses it. Any administrator can remove the last remaining other administrator, locking the entire system out of administrative access. The exploit does not require concurrent requests; sequential removals produce the same result. This issue has been patched in version 5.0.9.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2026-41662?

2 open source packages ship an affected version, including admidio/admidio.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `admidio/admidio` | Packagist | All versions | 5.0.9 |
| `admidio/admidio` | Packagist | All versions | 5.0.9 |

## How do I fix CVE-2026-41662?

Upgrade admidio/admidio to 5.0.9 or later.

## Is CVE-2026-41662 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41662 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41662 and fix it if it is affected.

What it is: CVE-2026-41662 is a medium-severity vulnerability in admidio, published on 7 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41662 exists.

Affected packages and fixed versions:
- admidio/admidio (Packagist): affected all versions; fixed in 5.0.9
- admidio/admidio (Packagist): affected all versions; fixed in 5.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41662/ (Markdown: https://insights.sbomify.com/CVE-2026-41662/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41662
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41662
- OSV: https://osv.dev/vulnerability/CVE-2026-41662

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41662/
Summaries are generated and may contain mistakes; the official description above is the record.
