# CVE-2026-41663: Admidio: CSRF on Admin Preferences Triggers Unauthorized Backup, .htaccess Write, and Email Send

> An attacker can force an authenticated admin to trigger unauthorized database backups, .htaccess writes, and email sends via CSRF in Admidio.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-rw74-vc9h-534j

## What is CVE-2026-41663?

CVE-2026-41663 is a low-severity vulnerability in admidio, published on 7 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Admidio is an open-source user management solution. Prior to version 5.0.9, several administrative operations in Admidio's preferences module (database backup, test email, htaccess generation) fire via GET requests with no CSRF token validation. Because SameSite=Lax cookies travel with top-level GET navigations, an attacker forces an authenticated admin to trigger these actions from a malicious page. This issue has been patched in version 5.0.9.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-41663?

2 open source packages ship an affected version, including admidio/admidio.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `admidio/admidio` | Packagist | All versions | 5.0.9 |
| `admidio/admidio` | Packagist | All versions | 5.0.9 |

## How do I fix CVE-2026-41663?

Upgrade admidio/admidio to 5.0.9 or later.

## Is CVE-2026-41663 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41663 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41663 and fix it if it is affected.

What it is: CVE-2026-41663 is a low-severity vulnerability in admidio, published on 7 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41663 exists.

Affected packages and fixed versions:
- admidio/admidio (Packagist): affected all versions; fixed in 5.0.9
- admidio/admidio (Packagist): affected all versions; fixed in 5.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41663/ (Markdown: https://insights.sbomify.com/CVE-2026-41663/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41663
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41663
- OSV: https://osv.dev/vulnerability/CVE-2026-41663

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41663/
Summaries are generated and may contain mistakes; the official description above is the record.
