# CVE-2026-41673: xmldom: Denial of service via uncontrolled recursion in XML serialization

> Attackers can crash applications using xmldom by providing deeply nested XML, causing stack overflow via uncontrolled recursion.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 28 Aug 2026
- **Also known as:** CLEANSTART-2026-NZ44243, CLEANSTART-2026-WO11970, DEBIAN-CVE-2026-41673, ECHO-822c-f1d2-8fbf, GHSA-2v35-w6hq-6mfw, MINI-4rhf-2434-9rp7, MINI-6hhc-8jr7-2xrw, MINI-9j88-hg4g-qw9x, MINI-mr7r-wmj9-87rq, ROOT-APP-NPM-CVE-2026-41673, UBUNTU-CVE-2026-41673

## What is CVE-2026-41673?

CVE-2026-41673 is a high-severity denial of service vulnerability in xmldom, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) `DOMParser` and `XMLSerializer` module. In @xmldom/xmldom prior to versions 0.9.10 and 0.8.13 and xmldom version 0.6.0 and prior, seven recursive traversals in lib/dom.js operate without a depth limit. A sufficiently deeply nested DOM tree causes a RangeError: Maximum call stack size exceeded, crashing the application. This issue has been patched in versions @xmldom/xmldom versions 0.9.10 and 0.8.13.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs), CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-41673?

6 open source packages ship an affected version, including @xmldom/xmldom and xmldom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@xmldom/xmldom` | npm | All versions | 0.8.13 |
| `@xmldom/xmldom` | npm | All versions | 0.8.13 |
| `@xmldom/xmldom` | npm | From 0.9.0 | 0.9.10 |
| `@xmldom/xmldom` | npm | From 0.9.0 | 0.9.10 |
| `xmldom` | npm | All versions to 0.6.0 | None |
| `xmldom` | npm | All versions to 0.6.0 | None |

## How do I fix CVE-2026-41673?

Upgrade @xmldom/xmldom to a fixed version for your release line: 0.8.13 or 0.9.10.

## Is CVE-2026-41673 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41673 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41673 and fix it if it is affected.

What it is: CVE-2026-41673 is a high-severity denial of service vulnerability in xmldom, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41673 exists.

Affected packages and fixed versions:
- @xmldom/xmldom (npm): affected all versions; fixed in 0.8.13
- @xmldom/xmldom (npm): affected all versions; fixed in 0.8.13
- @xmldom/xmldom (npm): affected from 0.9.0; fixed in 0.9.10
- @xmldom/xmldom (npm): affected from 0.9.0; fixed in 0.9.10
- xmldom (npm): affected all versions up to 0.6.0; no fix listed
- xmldom (npm): affected all versions up to 0.6.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41673/ (Markdown: https://insights.sbomify.com/CVE-2026-41673/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41673
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41673
- OSV: https://osv.dev/vulnerability/CVE-2026-41673

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41673/
Summaries are generated and may contain mistakes; the official description above is the record.
