CVE-2026-41674 xmldom: XML injection through unvalidated DocumentType serialization
Attackers can inject malicious XML markup via unvalidated DocumentType fields, potentially leading to code execution or data disclosure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41674?
CVE-2026-41674 is a high-severity vulnerability in xmldom, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) `DOMParser` and `XMLSerializer` module. In @xmldom/xmldom prior to versions 0.9.10 and 0.8.13 and xmldom version 0.6.0 and prior, the package serializes DocumentType node fields (internalSubset, publicId, systemId) verbatim without any escaping or validation. When these fields are set programmatically to attacker-controlled strings, XMLSerializer.serializeToString can produce output where the DOCTYPE declaration is terminated early and arbitrary markup appears outside it. This issue has been patched in versions @xmldom/xmldom versions 0.9.10 and 0.8.13.
Weakness: CWE-91
Which versions are affected by CVE-2026-41674?
6 open source packages ship an affected version, including @xmldom/xmldom and xmldom.
| Package | Affected | Fixed in |
|---|---|---|
@xmldom/xmldom npm | All versions | 0.8.13 |
@xmldom/xmldom npm | All versions | 0.8.13 |
@xmldom/xmldom npm | From 0.9.0 | 0.9.10 |
@xmldom/xmldom npm | From 0.9.0 | 0.9.10 |
xmldom npm | All versions to 0.6.0 | None |
xmldom npm | All versions to 0.6.0 | None |
How do I fix CVE-2026-41674?
Upgrade @xmldom/xmldom to a fixed version for your release line: 0.8.13 or 0.9.10.
Is CVE-2026-41674 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41674 exists.
Sources
Also known as CLEANSTART-2026-IV72379, CLEANSTART-2026-RM47121, CLSA-2026-1778114663, CLSA-2026-1786447648, DEBIAN-CVE-2026-41674, ECHO-6fce-c060-e9b9 and 7 more.