# CVE-2026-41674: xmldom: XML injection through unvalidated DocumentType serialization

> Attackers can inject malicious XML markup via unvalidated DocumentType fields, potentially leading to code execution or data disclosure.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 10 Sep 2026
- **Also known as:** CLEANSTART-2026-IV72379, CLEANSTART-2026-RM47121, CLSA-2026-1778114663, CLSA-2026-1786447648, DEBIAN-CVE-2026-41674, ECHO-6fce-c060-e9b9, GHSA-f6ww-3ggp-fr8h, MINI-47g3-6wc3-889f, MINI-5wp8-mc67-rgr2, MINI-gfpj-ghf9-x3vj, MINI-jrx6-59jr-mp4r, ROOT-APP-NPM-CVE-2026-41674, UBUNTU-CVE-2026-41674

## What is CVE-2026-41674?

CVE-2026-41674 is a high-severity vulnerability in xmldom, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) `DOMParser` and `XMLSerializer` module. In @xmldom/xmldom prior to versions 0.9.10 and 0.8.13 and xmldom version 0.6.0 and prior, the package serializes DocumentType node fields (internalSubset, publicId, systemId) verbatim without any escaping or validation. When these fields are set programmatically to attacker-controlled strings, XMLSerializer.serializeToString can produce output where the DOCTYPE declaration is terminated early and arbitrary markup appears outside it. This issue has been patched in versions @xmldom/xmldom versions 0.9.10 and 0.8.13.

Weakness: CWE-91 (XML Injection)

## Which versions are affected by CVE-2026-41674?

6 open source packages ship an affected version, including @xmldom/xmldom and xmldom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@xmldom/xmldom` | npm | All versions | 0.8.13 |
| `@xmldom/xmldom` | npm | All versions | 0.8.13 |
| `@xmldom/xmldom` | npm | From 0.9.0 | 0.9.10 |
| `@xmldom/xmldom` | npm | From 0.9.0 | 0.9.10 |
| `xmldom` | npm | All versions to 0.6.0 | None |
| `xmldom` | npm | All versions to 0.6.0 | None |

## How do I fix CVE-2026-41674?

Upgrade @xmldom/xmldom to a fixed version for your release line: 0.8.13 or 0.9.10.

## Is CVE-2026-41674 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41674 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41674 and fix it if it is affected.

What it is: CVE-2026-41674 is a high-severity vulnerability in xmldom, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41674 exists.

Affected packages and fixed versions:
- @xmldom/xmldom (npm): affected all versions; fixed in 0.8.13
- @xmldom/xmldom (npm): affected all versions; fixed in 0.8.13
- @xmldom/xmldom (npm): affected from 0.9.0; fixed in 0.9.10
- @xmldom/xmldom (npm): affected from 0.9.0; fixed in 0.9.10
- xmldom (npm): affected all versions up to 0.6.0; no fix listed
- xmldom (npm): affected all versions up to 0.6.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41674/ (Markdown: https://insights.sbomify.com/CVE-2026-41674/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41674
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41674
- OSV: https://osv.dev/vulnerability/CVE-2026-41674

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41674/
Summaries are generated and may contain mistakes; the official description above is the record.
