CVE-2026-41677 rust-openssl: Out-of-bounds read in PEM password callback when user callback returns an oversized length

Low 1.7 Published Updated

An out-of-bounds read in rust-openssl allows attackers to read memory or cause crashes via oversized password callback returns.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41677?

CVE-2026-41677 is a low-severity memory corruption vulnerability in rust-openssl, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.9.0 to before 0.10.78, the *_from_pem_callback APIs did not validate the length returned by the user's callback. A password callback that returns a value larger than the buffer it was given can cause some versions of OpenSSL to over-read this buffer. OpenSSL 3.x is not affected by this. This vulnerability is fixed in 0.10.78.

Weakness: CWE-1284, CWE-125

Which versions are affected by CVE-2026-41677?

2 open source packages ship an affected version, including openssl. It affects 1 product.

PackageAffectedFixed in
openssl crates.ioFrom 0.9.00.10.78
openssl crates.ioFrom 0.9.00.10.78

Products include Rust-Openssl Project Rust-Openssl.

How do I fix CVE-2026-41677?

Upgrade openssl to 0.10.78 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-41677 being exploited?

There is no known exploitation of CVE-2026-41677 in the wild and no public exploit code.

Sources

Also known as AZL-83621, DEBIAN-CVE-2026-41677, GHSA-xmgf-hq76-4vx2, MINI-25h5-3584-hvjm, MINI-28gj-w9c7-6jfw, MINI-49wx-842g-786p and 6 more.

Is CVE-2026-41677 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free