# CVE-2026-41677: rust-openssl: Out-of-bounds read in PEM password callback when user callback returns an oversized length

> An out-of-bounds read in rust-openssl allows attackers to read memory or cause crashes via oversized password callback returns.

- **Severity:** Low 1.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** AZL-83621, DEBIAN-CVE-2026-41677, GHSA-xmgf-hq76-4vx2, MINI-25h5-3584-hvjm, MINI-28gj-w9c7-6jfw, MINI-49wx-842g-786p, MINI-c497-3wjx-p8j4, MINI-j3r2-vfvr-xphc, MINI-j933-vhqf-742c, MINI-qfxh-g4q2-xcj3, MINI-w8cr-mp7q-p55f, UBUNTU-CVE-2026-41677

## What is CVE-2026-41677?

CVE-2026-41677 is a low-severity memory corruption vulnerability in rust-openssl, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

rust-openssl provides OpenSSL bindings for the Rust programming language.  From 0.9.0 to before 0.10.78, the *_from_pem_callback APIs did not validate the length returned by the user's callback. A password callback that returns a value larger than the buffer it was given can cause some versions of OpenSSL to over-read this buffer. OpenSSL 3.x is not affected by this. This vulnerability is fixed in 0.10.78.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-41677?

2 open source packages ship an affected version, including openssl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl` | crates.io | From 0.9.0 | 0.10.78 |
| `openssl` | crates.io | From 0.9.0 | 0.10.78 |

Products: Rust-Openssl Project Rust-Openssl.

## How do I fix CVE-2026-41677?

Upgrade openssl to 0.10.78 or later.

## Is CVE-2026-41677 being exploited?

There is no known exploitation of CVE-2026-41677 in the wild and no public exploit code.

## Other vulnerabilities in rust-openssl

- [CVE-2018-20997](https://insights.sbomify.com/CVE-2018-20997/): Use after free in openssl (critical 9.8)
- [CVE-2026-41898](https://insights.sbomify.com/CVE-2026-41898/): rust-openssl: Unchecked callback length in PSK/cookie trampolines leaks adjacent memory to peer (high 8.3)
- [CVE-2026-41681](https://insights.sbomify.com/CVE-2026-41681/): rust-openssl: MdCtxRef::digest_final() writes past caller buffer with no length check (high 8.1)
- [CVE-2016-10931](https://insights.sbomify.com/CVE-2016-10931/): Improper Certificate Validation in openssl (high 8.1)
- [CVE-2026-41676](https://insights.sbomify.com/CVE-2026-41676/): rust-openssl: Deriver::derive and PkeyCtxRef::derive can overflow short buffers on OpenSSL 1.1.1 (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41677 and fix it if it is affected.

What it is: CVE-2026-41677 is a low-severity memory corruption vulnerability in rust-openssl, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41677 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl (crates.io): affected from 0.9.0; fixed in 0.10.78
- openssl (crates.io): affected from 0.9.0; fixed in 0.10.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41677/ (Markdown: https://insights.sbomify.com/CVE-2026-41677/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41677
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41677
- OSV: https://osv.dev/vulnerability/CVE-2026-41677

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41677/
Summaries are generated and may contain mistakes; the official description above is the record.
