{"answers":{"affected":"2 open source packages ship an affected version, including openssl. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-41678 in the wild and no public exploit code.","fix":"Upgrade openssl to 0.10.78 or later.","what":"CVE-2026-41678 is a high-severity memory corruption vulnerability in rust-openssl, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41678 and fix it if it is affected.\n\nWhat it is: CVE-2026-41678 is a high-severity memory corruption vulnerability in rust-openssl, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-41678 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openssl (crates.io): affected from 0.10.24; fixed in 0.10.78\n- openssl (crates.io): affected from 0.10.24; fixed in 0.10.78\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41678/ (Markdown: https://insights.sbomify.com/CVE-2026-41678/index.md)","id":"CVE-2026-41678","markdown":"https://insights.sbomify.com/CVE-2026-41678/index.md","name":"CVE-2026-41678","record":{"aliases":["AZL-83615","DEBIAN-CVE-2026-41678","GHSA-8c75-8mhr-p7r9","MINI-2363-5jmc-frgm","MINI-4r6p-2rqw-6v2w","MINI-4xc4-w6pm-j9qm","MINI-58x9-8xhg-p8rq","MINI-5gcr-fr58-435p","MINI-6qp9-6qrw-7vrq","MINI-x2cq-8cpw-3j7p","MINI-xw4c-mh5v-fg5m","UBUNTU-CVE-2026-41678"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust OpenSSL bindings","requires_auth":"none","summary":"An incorrect bounds assertion in rust-openssl allows out-of-bounds writes, potentially leading to code execution or crashes.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"rust-openssl","vendor":"rust-openssl_project"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"rust-openssl provides OpenSSL bindings for the Rust programming language.  From  to before 0.10.78, aes::unwrap_key() contains an incorrect assertion: it checks that out.len() + 8 \u003c= in_.len(), but this condition is reversed. The intended invariant is out.len() \u003e= in_.len() - 8, ensuring the output buffer is large enough. Because of the inverted check, the function only accepts buffers at or below the minimum required size and rejects larger ones. If a smaller buffer is provided the function will write past the end of out by in_.len() - 8 - out.len() bytes, causing an out-of-bounds write from a safe public function. This vulnerability is fixed in 0.10.78.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"rust-openssl: Incorrect bounds assertion in aes key wrap","id":"CVE-2026-41678","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Paperclip Vulnerable to Unauthenticated Remote Code Execution via Import Authorization Bypass","id":"CVE-2026-41679"},"packages":[{"ecosystem":"crates.io","fixed":["0.10.78"],"introduced":["0.10.24"],"last_affected":[],"package":"openssl","purl":null,"source":"GHSA-8c75-8mhr-p7r9"},{"ecosystem":"crates.io","fixed":["0.10.78"],"introduced":["0.10.24"],"last_affected":[],"package":"openssl","purl":"pkg:cargo/openssl","source":"GHSA-8c75-8mhr-p7r9"}],"prev":{"headline":"rust-openssl: Out-of-bounds read in PEM password callback when user callback returns an oversized length","id":"CVE-2026-41677"},"products":["rust-openssl"],"published":"2026-04-24","related":[{"cvss_score":9.8,"headline":"Use after free in openssl","id":"CVE-2018-20997","kev_date_added":null,"published":"2019-08-26"},{"cvss_score":8.3,"headline":"rust-openssl: Unchecked callback length in PSK/cookie trampolines leaks adjacent memory to peer","id":"CVE-2026-41898","kev_date_added":null,"published":"2026-04-24"},{"cvss_score":8.1,"headline":"rust-openssl: MdCtxRef::digest_final() writes past caller buffer with no length check","id":"CVE-2026-41681","kev_date_added":null,"published":"2026-04-24"},{"cvss_score":8.1,"headline":"Improper Certificate Validation in openssl","id":"CVE-2016-10931","kev_date_added":null,"published":"2019-08-26"},{"cvss_score":7.2,"headline":"rust-openssl: Deriver::derive and PkeyCtxRef::derive can overflow short buffers on OpenSSL 1.1.1","id":"CVE-2026-41676","kev_date_added":null,"published":"2026-04-24"},{"cvss_score":1.7,"headline":"rust-openssl: Out-of-bounds read in PEM password callback when user callback returns an oversized length","id":"CVE-2026-41677","kev_date_added":null,"published":"2026-04-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-24","vendors":["rust-openssl"]},"summary":"An incorrect bounds assertion in rust-openssl allows out-of-bounds writes, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2026-41678/"}