# CVE-2026-41678: rust-openssl: Incorrect bounds assertion in aes key wrap

> An incorrect bounds assertion in rust-openssl allows out-of-bounds writes, potentially leading to code execution or crashes.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** AZL-83615, DEBIAN-CVE-2026-41678, GHSA-8c75-8mhr-p7r9, MINI-2363-5jmc-frgm, MINI-4r6p-2rqw-6v2w, MINI-4xc4-w6pm-j9qm, MINI-58x9-8xhg-p8rq, MINI-5gcr-fr58-435p, MINI-6qp9-6qrw-7vrq, MINI-x2cq-8cpw-3j7p, MINI-xw4c-mh5v-fg5m, UBUNTU-CVE-2026-41678

## What is CVE-2026-41678?

CVE-2026-41678 is a high-severity memory corruption vulnerability in rust-openssl, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

rust-openssl provides OpenSSL bindings for the Rust programming language.  From  to before 0.10.78, aes::unwrap_key() contains an incorrect assertion: it checks that out.len() + 8 <= in_.len(), but this condition is reversed. The intended invariant is out.len() >= in_.len() - 8, ensuring the output buffer is large enough. Because of the inverted check, the function only accepts buffers at or below the minimum required size and rejects larger ones. If a smaller buffer is provided the function will write past the end of out by in_.len() - 8 - out.len() bytes, causing an out-of-bounds write from a safe public function. This vulnerability is fixed in 0.10.78.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2026-41678?

2 open source packages ship an affected version, including openssl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl` | crates.io | From 0.10.24 | 0.10.78 |
| `openssl` | crates.io | From 0.10.24 | 0.10.78 |

Products: Rust-Openssl Project Rust-Openssl.

## How do I fix CVE-2026-41678?

Upgrade openssl to 0.10.78 or later.

## Is CVE-2026-41678 being exploited?

There is no known exploitation of CVE-2026-41678 in the wild and no public exploit code.

## Other vulnerabilities in rust-openssl

- [CVE-2018-20997](https://insights.sbomify.com/CVE-2018-20997/): Use after free in openssl (critical 9.8)
- [CVE-2026-41898](https://insights.sbomify.com/CVE-2026-41898/): rust-openssl: Unchecked callback length in PSK/cookie trampolines leaks adjacent memory to peer (high 8.3)
- [CVE-2026-41681](https://insights.sbomify.com/CVE-2026-41681/): rust-openssl: MdCtxRef::digest_final() writes past caller buffer with no length check (high 8.1)
- [CVE-2016-10931](https://insights.sbomify.com/CVE-2016-10931/): Improper Certificate Validation in openssl (high 8.1)
- [CVE-2026-41676](https://insights.sbomify.com/CVE-2026-41676/): rust-openssl: Deriver::derive and PkeyCtxRef::derive can overflow short buffers on OpenSSL 1.1.1 (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41678 and fix it if it is affected.

What it is: CVE-2026-41678 is a high-severity memory corruption vulnerability in rust-openssl, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41678 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl (crates.io): affected from 0.10.24; fixed in 0.10.78
- openssl (crates.io): affected from 0.10.24; fixed in 0.10.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41678/ (Markdown: https://insights.sbomify.com/CVE-2026-41678/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41678
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41678
- OSV: https://osv.dev/vulnerability/CVE-2026-41678

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41678/
Summaries are generated and may contain mistakes; the official description above is the record.
