# CVE-2026-41679: Paperclip Vulnerable to Unauthenticated Remote Code Execution via Import Authorization Bypass

> Unauthenticated attackers can achieve remote code execution on Paperclip instances via an import authorization bypass chain.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** GHSA-68qg-g8mg-6pr7

## What is CVE-2026-41679?

CVE-2026-41679 is a critical authentication bypass vulnerability in @paperclipai/server, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Paperclip is a Node.js server and React UI that orchestrates a team of AI agents to run a business. Prior to version 2026.416.0, an unauthenticated attacker can achieve full remote code execution on any network-accessible Paperclip instance running in `authenticated` mode with default configuration. No user interaction, no credentials, just the target's address. The chain consists of six API calls. The attack is fully automated, requires no user interaction, and works against the default deployment configuration. Version 2026.416.0 patches the issue.

Weakness: CWE-862 (Missing Authorization), CWE-287 (Improper Authentication), CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2026-41679?

4 open source packages ship an affected version, including @paperclipai/server and paperclipai. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@paperclipai/server` | npm | All versions | 2026.410.0 |
| `@paperclipai/server` | npm | All versions | 2026.410.0 |
| `paperclipai` | npm | All versions | 2026.410.0 |
| `paperclipai` | npm | All versions | 2026.410.0 |

Products: Paperclip Paperclipai, Paperclip Paperclipai\/Server.

## How do I fix CVE-2026-41679?

Upgrade @paperclipai/server to 2026.410.0 or later.

## Is CVE-2026-41679 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41679 exists.

Public exploit code:

- Paperclip AI RCE using a chain of six API calls (CVE-2026-41679). (metasploit)
- https://github.com/bartfroklage/cve-2026-41679 (github_poc): https://github.com/bartfroklage/cve-2026-41679
- Paperclip - Remote Code Execution (nuclei): http/cves/2026/CVE-2026-41679.yaml

## Other vulnerabilities in @paperclipai/server

- [CVE-2026-41208](https://insights.sbomify.com/CVE-2026-41208/): Paperclip: Privilege Escalation via Agent-Controlled workspaceStrategy.provisionCommand Leading to OS Command Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41679 and fix it if it is affected.

What it is: CVE-2026-41679 is a critical authentication bypass vulnerability in @paperclipai/server, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41679 exists.

Affected packages and fixed versions:
- @paperclipai/server (npm): affected all versions; fixed in 2026.410.0
- @paperclipai/server (npm): affected all versions; fixed in 2026.410.0
- paperclipai (npm): affected all versions; fixed in 2026.410.0
- paperclipai (npm): affected all versions; fixed in 2026.410.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41679/ (Markdown: https://insights.sbomify.com/CVE-2026-41679/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41679
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41679
- OSV: https://osv.dev/vulnerability/CVE-2026-41679

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41679/
Summaries are generated and may contain mistakes; the official description above is the record.
