CVE-2026-41681 rust-openssl: MdCtxRef::digest_final() writes past caller buffer with no length check

High 8.1 Published Updated

Attackers can trigger stack corruption via buffer overflow in digest_final, potentially leading to code execution or crashes in Rust applications using rust-openssl.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41681?

CVE-2026-41681 is a high-severity memory corruption vulnerability in rust-openssl, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.10.39 to before 0.10.78, EVP_DigestFinal() always writes EVP_MD_CTX_size(ctx) to the out buffer. If out is smaller than that, MdCtxRef::digest_final() writes past its end, usually corrupting the stack. This is reachable from safe Rust. This vulnerability is fixed in 0.10.78.

Weakness: CWE-121

Which versions are affected by CVE-2026-41681?

2 open source packages ship an affected version, including openssl. It affects 1 product.

PackageAffectedFixed in
openssl crates.ioFrom 0.10.390.10.78
openssl crates.ioFrom 0.10.390.10.78

Products include Rust-Openssl Project Rust-Openssl.

How do I fix CVE-2026-41681?

Upgrade openssl to 0.10.78 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-41681 being exploited?

There is no known exploitation of CVE-2026-41681 in the wild and no public exploit code.

Sources

Also known as AZL-83624, DEBIAN-CVE-2026-41681, GHSA-ghm9-cr32-g9qj, MINI-3vcv-5364-gfg5, MINI-4649-5mpw-6f4q, MINI-5h45-h27x-wp6r and 6 more.

Is CVE-2026-41681 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free