# CVE-2026-41681: rust-openssl: MdCtxRef::digest_final() writes past caller buffer with no length check

> Attackers can trigger stack corruption via buffer overflow in digest_final, potentially leading to code execution or crashes in Rust applications using rust-openssl.

- **Severity:** High 8.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** AZL-83624, DEBIAN-CVE-2026-41681, GHSA-ghm9-cr32-g9qj, MINI-3vcv-5364-gfg5, MINI-4649-5mpw-6f4q, MINI-5h45-h27x-wp6r, MINI-763g-5jcc-w2fw, MINI-ch9w-85v4-35xx, MINI-ghrm-7fj2-c26f, MINI-gj76-h2g8-5xqc, MINI-wgv7-mp9h-7f24, UBUNTU-CVE-2026-41681

## What is CVE-2026-41681?

CVE-2026-41681 is a high-severity memory corruption vulnerability in rust-openssl, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

rust-openssl provides OpenSSL bindings for the Rust programming language.  From 0.10.39 to before 0.10.78, EVP_DigestFinal() always writes EVP_MD_CTX_size(ctx) to the out buffer. If out is smaller than that, MdCtxRef::digest_final() writes past its end, usually corrupting the stack. This is reachable from safe Rust. This vulnerability is fixed in 0.10.78.

Weakness: CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2026-41681?

2 open source packages ship an affected version, including openssl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl` | crates.io | From 0.10.39 | 0.10.78 |
| `openssl` | crates.io | From 0.10.39 | 0.10.78 |

Products: Rust-Openssl Project Rust-Openssl.

## How do I fix CVE-2026-41681?

Upgrade openssl to 0.10.78 or later.

## Is CVE-2026-41681 being exploited?

There is no known exploitation of CVE-2026-41681 in the wild and no public exploit code.

## Other vulnerabilities in rust-openssl

- [CVE-2018-20997](https://insights.sbomify.com/CVE-2018-20997/): Use after free in openssl (critical 9.8)
- [CVE-2026-41898](https://insights.sbomify.com/CVE-2026-41898/): rust-openssl: Unchecked callback length in PSK/cookie trampolines leaks adjacent memory to peer (high 8.3)
- [CVE-2016-10931](https://insights.sbomify.com/CVE-2016-10931/): Improper Certificate Validation in openssl (high 8.1)
- [CVE-2026-41676](https://insights.sbomify.com/CVE-2026-41676/): rust-openssl: Deriver::derive and PkeyCtxRef::derive can overflow short buffers on OpenSSL 1.1.1 (high 7.2)
- [CVE-2026-41678](https://insights.sbomify.com/CVE-2026-41678/): rust-openssl: Incorrect bounds assertion in aes key wrap (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41681 and fix it if it is affected.

What it is: CVE-2026-41681 is a high-severity memory corruption vulnerability in rust-openssl, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41681 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl (crates.io): affected from 0.10.39; fixed in 0.10.78
- openssl (crates.io): affected from 0.10.39; fixed in 0.10.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41681/ (Markdown: https://insights.sbomify.com/CVE-2026-41681/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41681
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41681
- OSV: https://osv.dev/vulnerability/CVE-2026-41681

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41681/
Summaries are generated and may contain mistakes; the official description above is the record.
