CVE-2026-41682 pupnp: Port truncation via atoi() cast in parse_uri() allows SSRF port confusion

Medium 6.9 Published Updated

Attackers can exploit port truncation in pupnp to cause SSRF port confusion, bypassing intended network restrictions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41682?

CVE-2026-41682 is a medium-severity server-side request forgery vulnerability in pupnp, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

pupnp is an SDK for development of UPnP device and control point applications. Prior to version 1.18.5, pupnp is vulnerable to SRRF port confusion due to port truncation via atoi() cast in parse_uri(). This issue has been patched in version 1.18.5.

Weakness: CWE-918, CWE-195

Which versions are affected by CVE-2026-41682?

Linux distribution packages (1)
libupnp openSUSE:TumbleweedAll versions1.18.5-1.1

How do I fix CVE-2026-41682?

Upgrade to a fixed version.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2026-41682 being exploited?

There is no known exploitation of CVE-2026-41682 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-41682, GHSA-q522-6w45-4j58, MGASA-2026-0223, UBUNTU-CVE-2026-41682, openSUSE-SU-2026:10641-1.

Is CVE-2026-41682 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free