# CVE-2026-41682: pupnp: Port truncation via atoi() cast in parse_uri() allows SSRF port confusion

> Attackers can exploit port truncation in pupnp to cause SSRF port confusion, bypassing intended network restrictions.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 11 May 2026
- **Also known as:** DEBIAN-CVE-2026-41682, GHSA-q522-6w45-4j58, MGASA-2026-0223, UBUNTU-CVE-2026-41682, openSUSE-SU-2026:10641-1

## What is CVE-2026-41682?

CVE-2026-41682 is a medium-severity server-side request forgery vulnerability in pupnp, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pupnp is an SDK for development of UPnP device and control point applications. Prior to version 1.18.5, pupnp is vulnerable to SRRF port confusion due to port truncation via atoi() cast in parse_uri(). This issue has been patched in version 1.18.5.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-195 (Signed to Unsigned Conversion Error)

## Which versions are affected by CVE-2026-41682?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libupnp` | openSUSE:Tumbleweed | All versions | 1.18.5-1.1 |

## How do I fix CVE-2026-41682?

Upgrade to a fixed version.

## Is CVE-2026-41682 being exploited?

There is no known exploitation of CVE-2026-41682 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41682 and fix it if it is affected.

What it is: CVE-2026-41682 is a medium-severity server-side request forgery vulnerability in pupnp, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41682 in the wild and no public exploit code.

Affected product: pupnp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41682/ (Markdown: https://insights.sbomify.com/CVE-2026-41682/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41682
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41682
- OSV: https://osv.dev/vulnerability/CVE-2026-41682

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41682/
Summaries are generated and may contain mistakes; the official description above is the record.
