{"answers":{"affected":"2 open source packages ship an affected version, including i18next-http-middleware.","exploited":"There is no known exploitation of CVE-2026-41683 in the wild and no public exploit code.","fix":"Upgrade i18next-http-middleware to 3.9.3 or later.","what":"CVE-2026-41683 is a high-severity vulnerability in i18next-http-middleware, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41683 and fix it if it is affected.\n\nWhat it is: CVE-2026-41683 is a high-severity vulnerability in i18next-http-middleware, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-41683 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- i18next-http-middleware (npm): affected all versions; fixed in 3.9.3\n- i18next-http-middleware (npm): affected all versions; fixed in 3.9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41683/ (Markdown: https://insights.sbomify.com/CVE-2026-41683/index.md)","id":"CVE-2026-41683","markdown":"https://insights.sbomify.com/CVE-2026-41683/index.md","name":"CVE-2026-41683","record":{"aliases":["GHSA-c3h8-g69v-pjrg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","other"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js i18n middleware","requires_auth":"none","summary":"Attackers can inject CRLF sequences into HTTP headers causing response splitting and denial of service in Node.js applications using vulnerable i18next middleware.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-113","name":"Improper Neutralization of CRLF Sequences in HTTP Headers"}],"description":"i18next-http-middleware is a middleware to be used with Node.js web frameworks like express or Fastify and also for Deno. Prior to version 3.9.3, i18next-http-middleware wrote user-controlled language values into the Content-Language response header after passing them through utils.escape(), which is an HTML-entity encoder that does not strip carriage return, line feed, or other control characters. When the application used an older i18next (\u003c 19.5.0) that still exercised the backward-compatibility fallback at LanguageDetector.js:100 or otherwise produced a raw detected value, CRLF sequences in the attacker-controlled lng parameter reached res.setHeader('Content-Language', ...) verbatim. This issue has been patched in version 3.9.3.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"HTTP response splitting and DoS in i18next-http-middleware via unsanitised Content-Language header","id":"CVE-2026-41683","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Incus: Nil Dereferences on Restore via Malformed YAML","id":"CVE-2026-41684"},"packages":[{"ecosystem":"npm","fixed":["3.9.3"],"introduced":["0"],"last_affected":[],"package":"i18next-http-middleware","purl":null,"source":"GHSA-c3h8-g69v-pjrg"},{"ecosystem":"npm","fixed":["3.9.3"],"introduced":["0"],"last_affected":[],"package":"i18next-http-middleware","purl":"pkg:npm/i18next-http-middleware","source":"GHSA-c3h8-g69v-pjrg"}],"prev":{"headline":"pupnp: Port truncation via atoi() cast in parse_uri() allows SSRF port confusion","id":"CVE-2026-41682"},"products":["i18next-http-middleware"],"published":"2026-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-08","vendors":["i18next"]},"summary":"Attackers can inject CRLF sequences into HTTP headers causing response splitting and denial of service in Node.js applications using vulnerable i18next middleware.","url":"https://insights.sbomify.com/CVE-2026-41683/"}