CVE-2026-41684 Incus: Nil Dereferences on Restore via Malformed YAML

Medium 6.5 Published Updated

An authenticated user can crash the Incus daemon by importing a crafted backup archive with malformed legacy configuration files.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41684?

CVE-2026-41684 is a medium-severity vulnerability in lxc incus, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Incus is a system container and virtual machine manager. Prior to version 7.0.0, backup.GetInfo() trusts the inline backup/index.yaml config when present and only falls back to parsing the legacy backup/container/backup.yaml file if result.Config == nil. As a result, an archive can carry a valid inline config that passes the initial import preflight while also carrying a malformed legacy backup/container/backup.yaml file that is reparsed later from the restored file system. ParseConfigYamlFile() accepts YAML documents with no container section, and multiple downstream consumers then dereference. Container without checking for nil. Confirmed examples in the instance restore and import flow include backup.UpdateInstanceConfig() and internalImportFromBackup(). An authenticated user with permission to import instance backups may be able to crash the Incus daemon with a crafted backup archive whose inline backup/index.yaml is valid but whose extracted legacy backup.yaml omits container. The crash occurs in the restore path after archive extraction has begun. This issue has been patched in version 7.0.0.

Weakness: CWE-476

Which versions are affected by CVE-2026-41684?

4 open source packages ship an affected version, including github.com/lxc/incus/v6/cmd/incusd, github.com/lxc/incus and github.com/lxc/incus/v6. It affects 1 product.

PackageAffectedFixed in
github.com/lxc/incus/v6/cmd/incusd GoAll versions to 6.23.0None
github.com/lxc/incus/v6/cmd/incusd GoAll versions to 6.23.0None
github.com/lxc/incus GoAll versionsNone
github.com/lxc/incus/v6 GoAll versionsNone

Products include Linuxcontainers Incus.

How do I fix CVE-2026-41684?

Upgrade to a fixed version.

Is CVE-2026-41684 being exploited?

There is no known exploitation of CVE-2026-41684 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-41684, GHSA-x5r6-jr56-89pv, GO-2026-5742, UBUNTU-CVE-2026-41684.

Is CVE-2026-41684 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free