# CVE-2026-41684: Incus: Nil Dereferences on Restore via Malformed YAML

> An authenticated user can crash the Incus daemon by importing a crafted backup archive with malformed legacy configuration files.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** DEBIAN-CVE-2026-41684, GHSA-x5r6-jr56-89pv, GO-2026-5742, UBUNTU-CVE-2026-41684

## What is CVE-2026-41684?

CVE-2026-41684 is a medium-severity vulnerability in lxc incus, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incus is a system container and virtual machine manager. Prior to version 7.0.0, backup.GetInfo() trusts the inline backup/index.yaml config when present and only falls back to parsing the legacy backup/container/backup.yaml file if result.Config == nil. As a result, an archive can carry a valid inline config that passes the initial import preflight while also carrying a malformed legacy backup/container/backup.yaml file that is reparsed later from the restored file system. ParseConfigYamlFile() accepts YAML documents with no container section, and multiple downstream consumers then dereference. Container without checking for nil. Confirmed examples in the instance restore and import flow include backup.UpdateInstanceConfig() and internalImportFromBackup(). An authenticated user with permission to import instance backups may be able to crash the Incus daemon with a crafted backup archive whose inline backup/index.yaml is valid but whose extracted legacy backup.yaml omits container. The crash occurs in the restore path after archive extraction has begun. This issue has been patched in version 7.0.0.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-41684?

4 open source packages ship an affected version, including github.com/lxc/incus/v6/cmd/incusd, github.com/lxc/incus and github.com/lxc/incus/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lxc/incus/v6/cmd/incusd` | Go | All versions to 6.23.0 | None |
| `github.com/lxc/incus/v6/cmd/incusd` | Go | All versions to 6.23.0 | None |
| `github.com/lxc/incus` | Go | All versions | None |
| `github.com/lxc/incus/v6` | Go | All versions | None |

Products: Linuxcontainers Incus.

## How do I fix CVE-2026-41684?

Upgrade to a fixed version.

## Is CVE-2026-41684 being exploited?

There is no known exploitation of CVE-2026-41684 in the wild and no public exploit code.

## Other vulnerabilities in lxc incus

- [CVE-2026-33897](https://insights.sbomify.com/CVE-2026-33897/): Incus vulnerable to arbitrary file read and write through pongo templates (critical 10.0)
- [CVE-2026-33945](https://insights.sbomify.com/CVE-2026-33945/): Abitrary file write through systemd-creds option (critical 10.0)
- [CVE-2026-33898](https://insights.sbomify.com/CVE-2026-33898/): Local Incus UI web server vulnerable to nuthentication bypass (high 8.8)
- [CVE-2026-23953](https://insights.sbomify.com/CVE-2026-23953/): Incus container environment configuration newline injection (high 8.7)
- [CVE-2026-23954](https://insights.sbomify.com/CVE-2026-23954/): Incus container image templating arbitrary host file read and write (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41684 and fix it if it is affected.

What it is: CVE-2026-41684 is a medium-severity vulnerability in lxc incus, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41684 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/lxc/incus/v6/cmd/incusd (Go): affected all versions up to 6.23.0; no fix listed
- github.com/lxc/incus/v6/cmd/incusd (Go): affected all versions up to 6.23.0; no fix listed
- github.com/lxc/incus (Go): affected all versions; no fix listed
- github.com/lxc/incus/v6 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41684/ (Markdown: https://insights.sbomify.com/CVE-2026-41684/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41684
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41684
- OSV: https://osv.dev/vulnerability/CVE-2026-41684

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41684/
Summaries are generated and may contain mistakes; the official description above is the record.
