# CVE-2026-41685: Incus: Unbounded binary import disk exhaustion

> Authenticated users can exhaust host disk space via large binary imports, causing denial of service unless specific storage volumes are configured.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** DEBIAN-CVE-2026-41685, GHSA-98vh-x9cx-9cfp, GO-2026-5280, UBUNTU-CVE-2026-41685

## What is CVE-2026-41685?

CVE-2026-41685 is a medium-severity denial of service vulnerability in lxc incus, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incus is a system container and virtual machine manager. Prior to version 7.0.0, uploads of large amount of data by authenticated users can run the Incus server out of disk space, potentially taking down the host system. The impact here is limited for anyone using storage.images_volume and storage.backups_volume as those users will have large uploads be stored on those volumes rather than directly on the host filesystem. This is the default behavior on IncusOS. This issue has been patched in version 7.0.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-41685?

4 open source packages ship an affected version, including github.com/lxc/incus/v6/cmd/incusd, github.com/lxc/incus and github.com/lxc/incus/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lxc/incus/v6/cmd/incusd` | Go | All versions to 6.23.0 | None |
| `github.com/lxc/incus/v6/cmd/incusd` | Go | All versions to 6.23.0 | None |
| `github.com/lxc/incus` | Go | All versions | None |
| `github.com/lxc/incus/v6` | Go | All versions | None |

Products: Linuxcontainers Incus.

## How do I fix CVE-2026-41685?

Upgrade to a fixed version.

## Is CVE-2026-41685 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41685 exists.

## Other vulnerabilities in lxc incus

- [CVE-2026-33897](https://insights.sbomify.com/CVE-2026-33897/): Incus vulnerable to arbitrary file read and write through pongo templates (critical 10.0)
- [CVE-2026-33945](https://insights.sbomify.com/CVE-2026-33945/): Abitrary file write through systemd-creds option (critical 10.0)
- [CVE-2026-33898](https://insights.sbomify.com/CVE-2026-33898/): Local Incus UI web server vulnerable to nuthentication bypass (high 8.8)
- [CVE-2026-23953](https://insights.sbomify.com/CVE-2026-23953/): Incus container environment configuration newline injection (high 8.7)
- [CVE-2026-23954](https://insights.sbomify.com/CVE-2026-23954/): Incus container image templating arbitrary host file read and write (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41685 and fix it if it is affected.

What it is: CVE-2026-41685 is a medium-severity denial of service vulnerability in lxc incus, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41685 exists.

Affected packages and fixed versions:
- github.com/lxc/incus/v6/cmd/incusd (Go): affected all versions up to 6.23.0; no fix listed
- github.com/lxc/incus/v6/cmd/incusd (Go): affected all versions up to 6.23.0; no fix listed
- github.com/lxc/incus (Go): affected all versions; no fix listed
- github.com/lxc/incus/v6 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41685/ (Markdown: https://insights.sbomify.com/CVE-2026-41685/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41685
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41685
- OSV: https://osv.dev/vulnerability/CVE-2026-41685

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41685/
Summaries are generated and may contain mistakes; the official description above is the record.
