# CVE-2026-41687: Wallos: SSRF CGNAT Bypass in subscription/payments Logo URL — is_cgnat_ip() Not Used in Inline Checks

> Authenticated users can bypass SSRF protections to access internal services in CGNAT environments via logo URL fields.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-4v59-hghw-7gc2

## What is CVE-2026-41687?

CVE-2026-41687 is a medium-severity server-side request forgery vulnerability in ellite Wallos, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Wallos is an open-source, self-hostable personal subscription tracker. Prior to version 4.8.1, the SSRF protection in endpoints/subscription/add.php (line 42) and endpoints/payments/add.php (line 40) uses an inline IP validation check (FILTER_FLAG_NO_PRIV_RANGE | FILTER_FLAG_NO_RES_RANGE) that does not block CGNAT addresses (100.64.0.0/10, RFC 6598). The includes/ssrf_helper.php file explicitly defines is_cgnat_ip() to cover this gap (used by notification endpoints), but the logo/icon URL fetching in subscription and payment endpoints performs its own inline validation that misses this range. This allows authenticated users to perform Blind SSRF to internal services in Tailscale, Carrier-Grade NAT, and other environments using 100.64.0.0/10 addresses. This issue has been patched in version 4.8.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-41687?


## How do I fix CVE-2026-41687?

No fix has been published for CVE-2026-41687 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-41687 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41687 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41687 and fix it if it is affected.

What it is: CVE-2026-41687 is a medium-severity server-side request forgery vulnerability in ellite Wallos, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41687 exists.

Affected product: ellite Wallos. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41687/ (Markdown: https://insights.sbomify.com/CVE-2026-41687/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41687
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41687
- OSV: https://osv.dev/vulnerability/CVE-2026-41687

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41687/
Summaries are generated and may contain mistakes; the official description above is the record.
