# CVE-2026-41690: Prototype pollution and path traversal in i18next-http-middleware via user-controlled language and namespace parameters

> Unauthenticated attackers can pollute prototypes via path traversal, leading to authorization bypass and potential remote code execution in Node.js applications.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-5fgg-jcpf-8jjw

## What is CVE-2026-41690?

CVE-2026-41690 is a high-severity path traversal vulnerability in i18next-http-middleware, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

18next-http-middleware is a middleware to be used with Node.js web frameworks like express or Fastify and also for Deno. Versions prior to 3.9.3 allow an unauthenticated HTTP client to pollute Object.prototype in the Node.js process hosting the middleware, via two unvalidated entry points that reach internal object-key writes: getResourcesHandler and missingKeyHandler. This can break authorisation checks (if (user.isAdmin) returning true for any user), cause type-confusion DoS, and depending on downstream code  it can be chained into RCE.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-41690?

2 open source packages ship an affected version, including i18next-http-middleware.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `i18next-http-middleware` | npm | All versions | 3.9.3 |
| `i18next-http-middleware` | npm | All versions | 3.9.3 |

## How do I fix CVE-2026-41690?

Upgrade i18next-http-middleware to 3.9.3 or later.

## Is CVE-2026-41690 being exploited?

There is no known exploitation of CVE-2026-41690 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41690 and fix it if it is affected.

What it is: CVE-2026-41690 is a high-severity path traversal vulnerability in i18next-http-middleware, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41690 in the wild and no public exploit code.

Affected packages and fixed versions:
- i18next-http-middleware (npm): affected all versions; fixed in 3.9.3
- i18next-http-middleware (npm): affected all versions; fixed in 3.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41690/ (Markdown: https://insights.sbomify.com/CVE-2026-41690/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41690
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41690
- OSV: https://osv.dev/vulnerability/CVE-2026-41690

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41690/
Summaries are generated and may contain mistakes; the official description above is the record.
