# CVE-2026-41691: i18next-http-backend has Path Traversal & URL Injection via Unsanitised lng/ns

> Attackers can inject path traversal or URL structures via unsanitized language/namespace inputs, potentially accessing unauthorized resources or bypassing security controls.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 8 May 2026
- **Also known as:** DEBIAN-CVE-2026-41691, GHSA-q89c-q3h5-w34g

## What is CVE-2026-41691?

CVE-2026-41691 is a medium-severity path traversal vulnerability in i18next-http-backend, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Copilot said: i18nextify is a JavaScript library that adds
i18nextify is a JavaScript library that adds website internationalization via a script tag, without source code changes. Versions prior to 3.0.5 interpolate the lng and ns values directly into the configured loadPath / addPath URL template without any encoding, validation, or path sanitisation. When an application exposes the language-code selection to user-controlled input (the default — i18next-browser-languagedetector reads ?lng= query params, cookies, localStorage, and request headers), an attacker can inject characters that change the structure of the outgoing request URL. This is a single URL-injection vulnerability. The attacker-controlled value is neutralised before it is used as part of an output URL string; the attack shape covers both path traversal and broader URL-structure injection — both are closed by the one interpolateUrl sanitisation fix. This issue has been fixed in version 3.0.5. If users cannot upgrade immediately, they can work around the issue by sanitising lng / ns before they reach i18next (strip .., /, \, ?, #, %, whitespace, and control characters; cap the length).

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-41691?

2 open source packages ship an affected version, including i18next-http-backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `i18next-http-backend` | npm | All versions | 3.0.5 |
| `i18next-http-backend` | npm | All versions | 3.0.5 |

Products: I18next I18next-Http-Backend.

## How do I fix CVE-2026-41691?

Upgrade i18next-http-backend to 3.0.5 or later.

## Is CVE-2026-41691 being exploited?

There is no known exploitation of CVE-2026-41691 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41691 and fix it if it is affected.

What it is: CVE-2026-41691 is a medium-severity path traversal vulnerability in i18next-http-backend, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41691 in the wild and no public exploit code.

Affected packages and fixed versions:
- i18next-http-backend (npm): affected all versions; fixed in 3.0.5
- i18next-http-backend (npm): affected all versions; fixed in 3.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41691/ (Markdown: https://insights.sbomify.com/CVE-2026-41691/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41691
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41691
- OSV: https://osv.dev/vulnerability/CVE-2026-41691

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41691/
Summaries are generated and may contain mistakes; the official description above is the record.
