{"answers":{"affected":"2 open source packages ship an affected version, including i18nextify. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-41692 in the wild and no public exploit code.","fix":"Upgrade i18nextify to 4.0.8 or later.","what":"CVE-2026-41692 is a medium-severity cross-site scripting vulnerability in i18nextify, published on 7 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-41692 and fix it if it is affected.\n\nWhat it is: CVE-2026-41692 is a medium-severity cross-site scripting vulnerability in i18nextify, published on 7 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-41692 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- i18nextify (npm): affected all versions; fixed in 4.0.8\n- i18nextify (npm): affected all versions; fixed in 4.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41692/ (Markdown: https://insights.sbomify.com/CVE-2026-41692/index.md)","id":"CVE-2026-41692","markdown":"https://insights.sbomify.com/CVE-2026-41692/index.md","name":"CVE-2026-41692","record":{"aliases":["GHSA-6457-mxpq-4fqq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript i18n library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in victim browsers by injecting malicious URL schemes into translation files processed by the i18nextify library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"i18nextify","vendor":"i18next"}],"cvss":{"score":4.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"i18nextify is a JavaScript library that adds website internationalization via a script tag, without source code changes. Versions prior to 4.0.8 substitute {{key}} interpolation tokens inside src and href attribute values with the raw string returned by i18next.t(). The substitution logic in src/localize.js (the replaceInside handler) only guards against a duplicated http:// origin prefix — it does not validate the URL scheme of the substituted value. A translated value such as javascript:alert(1) or data:text/html,\u003cscript\u003e...\u003c/script\u003e is applied unchanged to the live DOM attribute when an attacker can influence the content of a translation file or the translation-backend response — for example, via a compromised translation CDN, user-contributed locales, a MITM on a plain-HTTP backend, or write access to the translation JSON. This issue was patched in version 4.0.8.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"i18nextify is vulnerable to DOM XSS via javascript:/data: URL schemes in translated href/src attributes","id":"CVE-2026-41692","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"i18next-fs-backend: Path traversal via unsanitised lng/ns allows arbitrary file read/overwrite","id":"CVE-2026-41693"},"packages":[{"ecosystem":"npm","fixed":["4.0.8"],"introduced":["0"],"last_affected":[],"package":"i18nextify","purl":null,"source":"GHSA-6457-mxpq-4fqq"},{"ecosystem":"npm","fixed":["4.0.8"],"introduced":["0"],"last_affected":[],"package":"i18nextify","purl":"pkg:npm/i18nextify","source":"GHSA-6457-mxpq-4fqq"}],"prev":{"headline":"i18next-http-backend has Path Traversal \u0026 URL Injection via Unsanitised lng/ns","id":"CVE-2026-41691"},"products":["i18nextify"],"published":"2026-05-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-11","vendors":["i18next"]},"summary":"Attackers can execute arbitrary JavaScript in victim browsers by injecting malicious URL schemes into translation files processed by the i18nextify library.","url":"https://insights.sbomify.com/CVE-2026-41692/"}