# CVE-2026-41692: i18nextify is vulnerable to DOM XSS via javascript:/data: URL schemes in translated href/src attributes

> Attackers can execute arbitrary JavaScript in victim browsers by injecting malicious URL schemes into translation files processed by the i18nextify library.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-6457-mxpq-4fqq

## What is CVE-2026-41692?

CVE-2026-41692 is a medium-severity cross-site scripting vulnerability in i18nextify, published on 7 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

i18nextify is a JavaScript library that adds website internationalization via a script tag, without source code changes. Versions prior to 4.0.8 substitute {{key}} interpolation tokens inside src and href attribute values with the raw string returned by i18next.t(). The substitution logic in src/localize.js (the replaceInside handler) only guards against a duplicated http:// origin prefix — it does not validate the URL scheme of the substituted value. A translated value such as javascript:alert(1) or data:text/html,<script>...</script> is applied unchanged to the live DOM attribute when an attacker can influence the content of a translation file or the translation-backend response — for example, via a compromised translation CDN, user-contributed locales, a MITM on a plain-HTTP backend, or write access to the translation JSON. This issue was patched in version 4.0.8.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-41692?

2 open source packages ship an affected version, including i18nextify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `i18nextify` | npm | All versions | 4.0.8 |
| `i18nextify` | npm | All versions | 4.0.8 |

Products: I18next I18nextify.

## How do I fix CVE-2026-41692?

Upgrade i18nextify to 4.0.8 or later.

## Is CVE-2026-41692 being exploited?

There is no known exploitation of CVE-2026-41692 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41692 and fix it if it is affected.

What it is: CVE-2026-41692 is a medium-severity cross-site scripting vulnerability in i18nextify, published on 7 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-41692 in the wild and no public exploit code.

Affected packages and fixed versions:
- i18nextify (npm): affected all versions; fixed in 4.0.8
- i18nextify (npm): affected all versions; fixed in 4.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41692/ (Markdown: https://insights.sbomify.com/CVE-2026-41692/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41692
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41692
- OSV: https://osv.dev/vulnerability/CVE-2026-41692

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41692/
Summaries are generated and may contain mistakes; the official description above is the record.
