{"answers":{"affected":"2 open source packages ship an affected version, including i18next-fs-backend.","exploited":"There is no known exploitation of CVE-2026-41693 in the wild and no public exploit code.","fix":"Upgrade i18next-fs-backend to 2.6.4 or later.","what":"CVE-2026-41693 is a high-severity path traversal vulnerability in i18next-fs-backend, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41693 and fix it if it is affected.\n\nWhat it is: CVE-2026-41693 is a high-severity path traversal vulnerability in i18next-fs-backend, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-41693 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- i18next-fs-backend (npm): affected all versions; fixed in 2.6.4\n- i18next-fs-backend (npm): affected all versions; fixed in 2.6.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41693/ (Markdown: https://insights.sbomify.com/CVE-2026-41693/index.md)","id":"CVE-2026-41693","markdown":"https://insights.sbomify.com/CVE-2026-41693/index.md","name":"CVE-2026-41693","record":{"aliases":["GHSA-8847-338w-5hcj","MINI-2285-g6gg-j54g","MINI-rv6g-w6cj-c26r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js i18n backend","requires_auth":"none","summary":"Attackers can read or overwrite arbitrary files by manipulating language or namespace parameters in i18next-fs-backend due to unsanitized path interpolation.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-73","name":"External Control of File Name or Path"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"i18next-fs-backend is a backend layer for i18next using in Node.js and for Deno to load translations from the filesystem. Prior to version 2.6.4, i18next-fs-backend substitutes the lng and ns options directly into the configured loadPath / addPath templates and then read / write the resulting file from disk. The interpolation is unencoded and unvalidated, so a crafted lng or ns value — containing .., a path separator, a control character, a prototype key, or simply an unexpectedly long string — allows an attacker who can influence either value to read or overwrite files outside the intended locale directory. When lng / ns are derived from untrusted input (request-scoped i18next instances behind an HTTP layer such as i18next-http-middleware, or any framework that lets the end user pick the language via query string, cookie, or header), a single request such as ?lng=../../../../etc/passwd causes the backend to attempt to read that path. This issue has been patched in version 2.6.4.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"i18next-fs-backend: Path traversal via unsanitised lng/ns allows arbitrary file read/overwrite","id":"CVE-2026-41693","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"SAML Payloads Decrypted Without Valid Signature","id":"CVE-2026-41694"},"packages":[{"ecosystem":"npm","fixed":["2.6.4"],"introduced":["0"],"last_affected":[],"package":"i18next-fs-backend","purl":null,"source":"GHSA-8847-338w-5hcj"},{"ecosystem":"npm","fixed":["2.6.4"],"introduced":["0"],"last_affected":[],"package":"i18next-fs-backend","purl":"pkg:npm/i18next-fs-backend","source":"GHSA-8847-338w-5hcj"}],"prev":{"headline":"i18nextify is vulnerable to DOM XSS via javascript:/data: URL schemes in translated href/src attributes","id":"CVE-2026-41692"},"products":["i18next-fs-backend"],"published":"2026-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-13","vendors":["i18next"]},"summary":"Attackers can read or overwrite arbitrary files by manipulating language or namespace parameters in i18next-fs-backend due to unsanitized path interpolation.","url":"https://insights.sbomify.com/CVE-2026-41693/"}