CVE-2026-41694 SAML Payloads Decrypted Without Valid Signature
Attackers can bypass SAML signature validation to use the Service Provider as a decryption oracle, potentially exposing sensitive data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41694?
CVE-2026-41694 is a low-severity vulnerability in Spring Security, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Since Spring Security SAML decrypts SAML Responses as well as elements of SAML LogoutRequests and LogoutResponses without requiring a valid signature, attackers may be able to craft these SAML payloads and use the Service Provider as a decryption oracle.
Affected versions: Spring Security 5.7.0 through 5.7.23; 5.8.0 through 5.8.25; 6.3.0 through 6.3.16; 6.4.0 through 6.4.16; 6.5.0 through 6.5.10; 7.0.0 through 7.0.5.
Weakness: CWE-347
Which versions are affected by CVE-2026-41694?
12 open source packages ship an affected version, including org.springframework.security:spring-security-saml2-service-provider. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework.security:spring-security-saml2-service-provider Maven | All versions to 5.7.23 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | All versions to 5.7.23 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 5.8.0 to 5.8.25 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 5.8.0 to 5.8.25 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.3.0 to 6.3.16 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.3.0 to 6.3.16 | None |
6 more packages
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.4.0 to 6.4.16 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.4.0 to 6.4.16 | None |
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.5.0 | 6.5.11 |
org.springframework.security:spring-security-saml2-service-provider Maven | From 6.5.0 | 6.5.11 |
org.springframework.security:spring-security-saml2-service-provider Maven | From 7.0.0 | 7.0.6 |
org.springframework.security:spring-security-saml2-service-provider Maven | From 7.0.0 | 7.0.6 |
Products include Vmware Spring Security.
How do I fix CVE-2026-41694?
Upgrade org.springframework.security:spring-security-saml2-service-provider to a fixed version for your release line: 6.5.11 or 7.0.6.
Is CVE-2026-41694 being exploited?
There is no known exploitation of CVE-2026-41694 in the wild and no public exploit code.
Other vulnerabilities in Spring Security
- CVE-2014-3527 Authorization Bypass in Spring Security
- CVE-2026-59354 Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata
- CVE-2026-59270 Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces
- CVE-2026-22732 Under Some Conditions Spring Security HTTP Headers Are not Written
- CVE-2023-34034 Access Control Bypass in Spring Security
Sources
Also known as CLEANSTART-2026-FU03579, CLEANSTART-2026-LX92179, CLEANSTART-2026-WC72798, CLSA-2026-1784682903, CLSA-2026-1784682907, CLSA-2026-1786541618 and 3 more.