# CVE-2026-41694: SAML Payloads Decrypted Without Valid Signature

> Attackers can bypass SAML signature validation to use the Service Provider as a decryption oracle, potentially exposing sensitive data.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 27 Jun 2026
- **Also known as:** CLEANSTART-2026-FU03579, CLEANSTART-2026-LX92179, CLEANSTART-2026-WC72798, CLSA-2026-1784682903, CLSA-2026-1784682907, CLSA-2026-1786541618, ECHO-d445-7863-a5b6, GHSA-ww38-37g9-m3q3, MINI-94m2-fj3p-h3x7

## What is CVE-2026-41694?

CVE-2026-41694 is a low-severity vulnerability in Spring Security, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Since Spring Security SAML decrypts SAML Responses as well as elements of SAML LogoutRequests and LogoutResponses without requiring a valid signature, attackers may be able to craft these SAML payloads and use the Service Provider as a decryption oracle.

Affected versions:
Spring Security 5.7.0 through 5.7.23; 5.8.0 through 5.8.25; 6.3.0 through 6.3.16; 6.4.0 through 6.4.16; 6.5.0 through 6.5.10; 7.0.0 through 7.0.5.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-41694?

12 open source packages ship an affected version, including org.springframework.security:spring-security-saml2-service-provider. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | All versions to 5.7.23 | None |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | All versions to 5.7.23 | None |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 5.8.0 to 5.8.25 | None |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 5.8.0 to 5.8.25 | None |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 6.3.0 to 6.3.16 | None |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 6.3.0 to 6.3.16 | None |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 6.4.0 to 6.4.16 | None |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 6.4.0 to 6.4.16 | None |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 6.5.0 | 6.5.11 |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 6.5.0 | 6.5.11 |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 7.0.0 | 7.0.6 |
| `org.springframework.security:spring-security-saml2-service-provider` | Maven | From 7.0.0 | 7.0.6 |

Products: Vmware Spring Security.

## How do I fix CVE-2026-41694?

Upgrade org.springframework.security:spring-security-saml2-service-provider to a fixed version for your release line: 6.5.11 or 7.0.6.

## Is CVE-2026-41694 being exploited?

There is no known exploitation of CVE-2026-41694 in the wild and no public exploit code.

## Other vulnerabilities in Spring Security

- [CVE-2014-3527](https://insights.sbomify.com/CVE-2014-3527/): Authorization Bypass in Spring Security (critical 9.8)
- [CVE-2026-59354](https://insights.sbomify.com/CVE-2026-59354/): Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata (critical 9.6)
- [CVE-2026-59270](https://insights.sbomify.com/CVE-2026-59270/): Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces (critical 9.4)
- [CVE-2026-22732](https://insights.sbomify.com/CVE-2026-22732/): Under Some Conditions Spring Security HTTP Headers Are not Written (critical 9.1)
- [CVE-2023-34034](https://insights.sbomify.com/CVE-2023-34034/): Access Control Bypass in Spring Security (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41694 and fix it if it is affected.

What it is: CVE-2026-41694 is a low-severity vulnerability in Spring Security, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41694 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected all versions up to 5.7.23; no fix listed
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected all versions up to 5.7.23; no fix listed
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 5.8.0 up to 5.8.25; no fix listed
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 5.8.0 up to 5.8.25; no fix listed
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 6.3.0 up to 6.3.16; no fix listed
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 6.3.0 up to 6.3.16; no fix listed
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 6.4.0 up to 6.4.16; no fix listed
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 6.4.0 up to 6.4.16; no fix listed
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 6.5.0; fixed in 6.5.11
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 6.5.0; fixed in 6.5.11
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 7.0.0; fixed in 7.0.6
- org.springframework.security:spring-security-saml2-service-provider (Maven): affected from 7.0.0; fixed in 7.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41694/ (Markdown: https://insights.sbomify.com/CVE-2026-41694/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41694
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41694
- OSV: https://osv.dev/vulnerability/CVE-2026-41694

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41694/
Summaries are generated and may contain mistakes; the official description above is the record.
